Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vararam
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics > Engine | Exhaust | Bolt-On | Drivetrain Modifications


Reply
 
Thread Tools
Old 04-02-2020, 10:38 PM   #29
Smitty CC
 
Smitty CC's Avatar
 
Drives: 2013 ZL1
Join Date: Jun 2019
Location: Nebraska
Posts: 121
Quote:
Originally Posted by JB'sZL1 View Post
It seems only non ZL1 owners are posting here (ZLI forum) how great the Petal Commander is. I don't see any Zl1 owners doing the same. And that is not a slight on non Z owners...just an observation.

Just sayin": $300 gets me porting, pulley or cai...something I can really chew on.
Yeah I don't think it would do well on a ZL1 as they don't "lag" at all.
I am not criticizing anyone but it is hard for me to visualize this device making a difference.
__________________
Headers, Pullies, Cam, heads, 102mmTB ...Ect …
Smitty CC is offline   Reply With Quote
Old 04-03-2020, 07:16 AM   #30
RobZL1
fo'shizZL1
 
RobZL1's Avatar
 
Drives: 2014 ZL1
Join Date: Aug 2017
Location: ATL
Posts: 649
I guess that goes to show how this is a very subjective thing.

I personally think the stock settings are terrible. For my foot, there's a decent dead-zone when you first touch the pedal where the throttle blade does nothing.
__________________
2014 Red Hot #1503 | TBD SAE | RotoFab | 28% OD | GP Tuning 2.5 Cam | 2" TSP LT's | JMS BAP | ID850 | TR7IX | MSD Wires | APEX Catch Can | Metco Breather | Monster LT1-S Triple | C&R HEX | RotoFab Res | Racing Brake Rotors | Self-Tuned w/ HPT
RobZL1 is offline   Reply With Quote
Old 04-03-2020, 09:54 AM   #31
JB'sZL1

 
Drives: 2013 ZL1 and 2019 Ram Laramie
Join Date: May 2017
Location: Milwaukee
Posts: 1,017
There is? Or was? You're heavily modified now Rob.
JB'sZL1 is offline   Reply With Quote
Old 04-03-2020, 11:15 AM   #32
RobZL1
fo'shizZL1
 
RobZL1's Avatar
 
Drives: 2014 ZL1
Join Date: Aug 2017
Location: ATL
Posts: 649
With the stock settings, I mean. I've got no dead spot now, because I fixed it in the tune. Even when it was just a pulley/headers/intake car, the stock settings had the dead spot. Regardless of mod level, the stock settings exhibited the dead spot on my car (and a couple of stock ZL1's I drove before I bought this one.) Maybe I've just got a really sensitive foot or something. Who knows.
__________________
2014 Red Hot #1503 | TBD SAE | RotoFab | 28% OD | GP Tuning 2.5 Cam | 2" TSP LT's | JMS BAP | ID850 | TR7IX | MSD Wires | APEX Catch Can | Metco Breather | Monster LT1-S Triple | C&R HEX | RotoFab Res | Racing Brake Rotors | Self-Tuned w/ HPT
RobZL1 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:29 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.