Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
dave@hennessey
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 04-06-2015, 01:23 PM   #1
CobraR
 
Drives: 2010 2SS
Join Date: Nov 2013
Location: Baltimore
Posts: 124
102mm Throttle body on TVS2300

Ok, lets beat this to death one more time

I am tempting to max out my tvs2300 setup, one of the last things left is open it up to a 102mm and throttle body.

I found an older post by Ray@RDS saying they were doing some testing and thought they might be onto the cause of the throttle plate closing/limp mode.

Anyone have anything on this? I hate to spend the 800 dollars on the machine work and throttle body to just have issues. However it looks like this could gain about 20-40 rwhp from what I have read in most cases.
CobraR is offline   Reply With Quote
Old 04-06-2015, 04:38 PM   #2
LuckyZL-1
Ragtop Rocket!!!
 
LuckyZL-1's Avatar
 
Drives: Black on Black Convertible
Join Date: Mar 2013
Location: San Antonio Texas
Posts: 809
Contact JessRayo on here I believe he finally worked out his problem.
__________________
ADM built 2013 Triple Black ZL-1 Convertible M6
ADM custom cam, LPE stage 2 heads with dual valve springs, LS-3 ported throttle body, LPE 2 piece pulley, LPE overdrive balancer, 10% overdrive pulley, ported supercharger inlet, ADM race intake system, stainless works 1-7/8 headers, Injector Dynamics injectors, ADM heat exchanger, ADM dual fuel pump system, ADM exhaust switch, ADM 3 tunes tuning package.
744rwhp 727rwtq
LuckyZL-1 is offline   Reply With Quote
Old 04-06-2015, 06:11 PM   #3
Trackman

 
Trackman's Avatar
 
Drives: 67RS Camaro ,Black 2013 ZL1
Join Date: Jun 2010
Location: Alberta
Posts: 1,409
If Ray at RDS can offer a guarantee that his "calibration" works go for it.
Larger throttle bodies in high HP applications have proven to make decent gains.
There is no proven cure for the reduced engine power issue that I know of yet.
Trackman is offline   Reply With Quote
Old 04-06-2015, 07:02 PM   #4
CobraR
 
Drives: 2010 2SS
Join Date: Nov 2013
Location: Baltimore
Posts: 124
That's what I was figuring, then the guy that tunes the car said just leave the stock one on it for now.
CobraR is offline   Reply With Quote
Old 04-06-2015, 08:13 PM   #5
lexlueger


 
lexlueger's Avatar
 
Drives: V10 BMW M5, Supercharged 2SS/RS
Join Date: Jun 2010
Location: Charlotte NC /Brooklyn NY
Posts: 2,305
Been running a 102 for years no issues. The problem was with NW TB's. MY TPIS solved this in 09....

Well maybe not 09 but you get the point, lol
__________________
MAST 416 STROKER: STAGE 3 TVS 2300
CUSTOM CAM
TPIS 102 TB
IW 8 RIB PULLEY W/ OD COG REARS
NX EXPRESS/NANO KIT

KDI HEAT EXCHANGER/ROTOFAB RESERVOIR
CIRCLE D 2800 TC/FLEX PLATE/ADM TRANS COOLER
DSS DRIVESHAFT/1400 HP AXLES
EATON TRUETRAC -LPE 3.27 GEARS
DYNATECH HEADERS/MAGNAFLOW EXHAUST
SQUASH RETURN STYLE FS ID 850's E85/ FLEXFUEL
BMR/EIBACH SUSPENSION

KILL MODE, ON.


lexlueger is offline   Reply With Quote
Old 04-06-2015, 08:45 PM   #6
H-E
Account Suspended
 
Drives: 2010 zr1 Camaro 2011 vert
Join Date: Apr 2013
Location: everywhere
Posts: 1,121
Quote:
Originally Posted by LuckyZL-1 View Post
Contact JessRayo on here I believe he finally worked out his problem.
We used one of our tricks to help jess and may be offering this to others
H-E is offline   Reply With Quote
Old 04-06-2015, 09:25 PM   #7
CobraR
 
Drives: 2010 2SS
Join Date: Nov 2013
Location: Baltimore
Posts: 124
I didn't see the tpis even being offered right now.

H-E I will give you a call tomorrow.
CobraR is offline   Reply With Quote
Old 04-06-2015, 10:28 PM   #8
Trackman

 
Trackman's Avatar
 
Drives: 67RS Camaro ,Black 2013 ZL1
Join Date: Jun 2010
Location: Alberta
Posts: 1,409
Quote:
Originally Posted by H-E View Post
We used one of our tricks to help jess and may be offering this to others
I know of a throttle body that had the air foil design and it failed.
Trackman is offline   Reply With Quote
Old 04-06-2015, 10:34 PM   #9
Trackman

 
Trackman's Avatar
 
Drives: 67RS Camaro ,Black 2013 ZL1
Join Date: Jun 2010
Location: Alberta
Posts: 1,409
Quote:
Originally Posted by lexlueger View Post
Been running a 102 for years no issues. The problem was with NW TB's. MY TPIS solved this in 09....

Well maybe not 09 but you get the point, lol
When I was at the Texas mile last year it was still a common problem on big HP cars. I think there are a few rare units out there that seem to have a little extra tq needed to stay open. I don't know for a fact but I think speed density tunes have better luck at staying open as well.
Trackman is offline   Reply With Quote
Old 04-07-2015, 10:09 AM   #10
swiftkart
 
swiftkart's Avatar
 
Drives: 2010 SS/RS LS3 M6
Join Date: Apr 2011
Location: Kansas
Posts: 693
2 years and no problems with my NW102 at over 800rwhp.
swiftkart is offline   Reply With Quote
Old 01-17-2018, 04:14 PM   #11
hou30guy

 
Drives: 2011 convertible 2ss/rs
Join Date: Sep 2015
Location: Houston
Posts: 971
Quote:
Originally Posted by swiftkart View Post
2 years and no problems with my NW102 at over 800rwhp.
Regular nw 102mm or the boosted version

Sent from my SM-N950U using Tapatalk
hou30guy is offline   Reply With Quote
Old 01-18-2018, 06:41 AM   #12
Bildo

 
Bildo's Avatar
 
Drives: 2012 2SS/RS LS3
Join Date: Dec 2011
Location: Omaha, Nebraska
Posts: 1,663
NW told me directly only positive displacement super chargers create the problem with his setups.
__________________
2012 2SS M6, ERL Superdeck 6 427, PRC 255 Heads, Procharger F1A w/ 3.85 pulley, 1300hp intercooler, Squash Dual 450lph, E85, ID1700, RXT Clutch, DSS 1pc driveshaft, GForce axles, Eaton Detroit Trutrac, a bunch of other crap I don't feel like typing.
Bildo is offline   Reply With Quote
Old 01-18-2018, 07:53 AM   #13
hou30guy

 
Drives: 2011 convertible 2ss/rs
Join Date: Sep 2015
Location: Houston
Posts: 971
I have a nw and it wont stay open past 4600rpm and 14psi

Sent from my SM-N950U using Tapatalk
hou30guy is offline   Reply With Quote
Old 01-18-2018, 09:13 AM   #14
Pro-tuned
Angewendet Ingenieur
 
Pro-tuned's Avatar
 
Drives: 14 Camaro ZL1
Join Date: Apr 2015
Location: USA
Posts: 401
Running NW 102 with proper adapter 16 lbs.. no issue.
Pro-tuned is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:36 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.