Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Roto-Fab
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions


Reply
 
Thread Tools
Old 05-21-2021, 07:45 PM   #1
Teeth
 
Teeth's Avatar
 
Drives: 2010 Chevrolet Camaro SS
Join Date: Sep 2019
Location: Columbia, South Carolina
Posts: 212
Coolant leak

Running into weird issue, my radiator needs a top-off every other few days for some unknown reason.

No leak in engine, none in radiator, none anywhere I can see except where it might be shooting out of the res tank?

I installed a Mishi rad, meaning more coolant overall, would that mean I need a larger tank too? Loss of pressure in lines after a while too, but that's probably just because there is a coolant leak anyways.

Took it to a shop, they had no idea what was going on. Even watched them do all the diags on the car to see what they thought might have happened, they're puzzled too lol.
__________________
2010 Camaro 2SS/RS:
Cyber gray matte wrap, Danti Lambo style louvers, Granatelli Pro-stock look wing
B&M transcooler, Mishimoto oil cooler, Mishimoto catchcan, Borla/Pypebomb axle back
L99 to LS3 conversion, Vararam ram air intake, BTR Nightfury cam, Johnson lifters, LS7 injectors, Circle D 3200 stall converter, Kooks LT headers, Custom X-pipe
Teeth is offline   Reply With Quote
Old 05-21-2021, 08:08 PM   #2
Rmkuper
 
Rmkuper's Avatar
 
Drives: 2010 Camaro SS
Join Date: Oct 2020
Location: Newburgh
Posts: 156
Did you check the coolant crossover? A leak can be hard to detect from there and it's often overlooked. Make sure its torqued to 106 in lbs.*ITC makes a replacement that is a better design. There might be gaskets out there for them also I do t recall...

Sent from my SM-F916U using Tapatalk
Rmkuper is offline   Reply With Quote
Old 05-22-2021, 02:59 AM   #3
wasthatacop?
 
wasthatacop?'s Avatar
 
Drives: 2010 2SS
Join Date: Apr 2017
Location: Los Angeles
Posts: 361
Sounds like you have a small and tiny leak somewhere. I changed the water pump and radiator on my L99 last week. Radiator had a tiny crack and I couldn't figure out for the longest time where the coolant was leaking from.
Maybe a pinhole in a hose, it you reservoir is cracked. Also make sure the small 3/8" hose from radiator cap area is inserted into the reservoir neck.
__________________
2010 2SS living in Los Angeles
replaced engine @ 93,000 miles w/ crate engine, camshaft by Comp Cams installed by me, replaced valve train parts,
1.4" BMR lowering springs
ZL1 factory rims
misc: drilled and slotted rotors, fresh air brake cooling system, new speakers, installed reverse camera, muffler delete
wasthatacop? is offline   Reply With Quote
Old 05-22-2021, 12:49 PM   #4
Teeth
 
Teeth's Avatar
 
Drives: 2010 Chevrolet Camaro SS
Join Date: Sep 2019
Location: Columbia, South Carolina
Posts: 212
Thanks guys, I'll check around for whatever I can again
__________________
2010 Camaro 2SS/RS:
Cyber gray matte wrap, Danti Lambo style louvers, Granatelli Pro-stock look wing
B&M transcooler, Mishimoto oil cooler, Mishimoto catchcan, Borla/Pypebomb axle back
L99 to LS3 conversion, Vararam ram air intake, BTR Nightfury cam, Johnson lifters, LS7 injectors, Circle D 3200 stall converter, Kooks LT headers, Custom X-pipe
Teeth is offline   Reply With Quote
Old 05-22-2021, 11:03 PM   #5
Rmkuper
 
Rmkuper's Avatar
 
Drives: 2010 Camaro SS
Join Date: Oct 2020
Location: Newburgh
Posts: 156
If all else fails I think k you can get some uv dye at autozone for around 10 bucks.

Sent from my SM-F916U using Tapatalk
Rmkuper is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:43 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.