Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Solo Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LLT Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 10-29-2015, 11:11 AM   #1
Beemer
"Red Rocket"
 
Beemer's Avatar
 
Drives: 2010 Camaro 1LT
Join Date: Aug 2009
Location: Morgan Mill, Texas
Posts: 347
Busted air box clip - happy ending

So - have a trip planned for next month and thought it would be a good idea to check my air filter. I have a K&N reusable filter and have been very happy with it.

Oh, crap! The stupid plastic clip broke off! One clip was holding it fine but I really didn't want to risk it with a 4000 mile trip planned. I checked on prices to replace the filter box.

The price for a new box (have to buy the entire air intake system) wasn't terrible but I thought "What the heck! I've always wanted a CAI. Now's the time."

I wasn't really expecting much of a performance boost from the CAI system and I've always been very satisfied with the power produced by my V6 after 6 years and 56,000 miles. But I was blown away! The power increase is very apparent and the throttle-response is amazing! I should have done this YEARS ago.

I feel like I have a new car.

Anyone want to buy a slightly used stock air box with a K&N filter?
__________________
Beemer is offline   Reply With Quote
Old 10-29-2015, 12:54 PM   #2
redleader
redleader
 
Drives: 2010
Join Date: Mar 2012
Location: UK
Posts: 2,179
Good news in the end! :-)
redleader is offline   Reply With Quote
Old 10-29-2015, 03:54 PM   #3
W4rMach1ne
 
Drives: 2011 Camaro LT1
Join Date: Apr 2015
Location: Florida, United States
Posts: 337
What brand and model did you get?
W4rMach1ne is offline   Reply With Quote
Old 10-29-2015, 04:26 PM   #4
Dizzy82


 
Dizzy82's Avatar
 
Drives: 2011 1LT/RS A6 RJT SuperCharged
Join Date: Mar 2011
Location: 87114
Posts: 3,389
Another positive case of "perfect excuse to upgrade".
__________________
Power is worthless without control. The 2nd protects the 1st.
BMR sub frame brace, BMR tunnel brace, LSR sways, LSR CM ca & tl, Sphon ExD el, GM tower brace, Megan coil overs, Goodridge Stainless Steel Braided brake lines, PowerStop D/S rotors & pads, Doug Thorty Ceramic Shorties, Magnaflow x-pipe, MRT V2.0, KICKER PowerStage sub & amp, Infinity speakers & tweeters, Dynamat, Viteese Throttle Controller, Viteese Paddle Shifters, ACS T2 Splitter, ACS T2 Ports/Quad LED lights, VDI kit, Havoc diffuser, IPF ECU/TRANS tuned, IPF/KPE Supercharged. 364RWHP/297RWTQ
Dizzy82 is offline   Reply With Quote
Old 10-29-2015, 08:51 PM   #5
RubyCamaro
Jan
 
RubyCamaro's Avatar
 
Drives: 2010 Camaro 1LT Red Jewel tintcoat
Join Date: May 2010
Location: Springfield, TN
Posts: 15,984
See, we told ya so! Congrats on the upgrade.
__________________
RubyCamaro is offline   Reply With Quote
Old 10-29-2015, 08:58 PM   #6
km9v
 
Drives: 2011 Camaro SS/RS M6
Join Date: Oct 2010
Location: Beaumont, TX
Posts: 375
I did the same thing. Clip broke, perfect excuse for CAI.
km9v is offline   Reply With Quote
Old 10-30-2015, 08:23 AM   #7
Beemer
"Red Rocket"
 
Beemer's Avatar
 
Drives: 2010 Camaro 1LT
Join Date: Aug 2009
Location: Morgan Mill, Texas
Posts: 347
Quote:
Originally Posted by W4rMach1ne View Post
What brand and model did you get?
I got the black, powder coated model from CAI, Inc.

Love it.
__________________
Beemer is offline   Reply With Quote
Old 10-30-2015, 08:24 AM   #8
Beemer
"Red Rocket"
 
Beemer's Avatar
 
Drives: 2010 Camaro 1LT
Join Date: Aug 2009
Location: Morgan Mill, Texas
Posts: 347
Quote:
Originally Posted by RubyCamaro View Post
See, we told ya so! Congrats on the upgrade.
Hey - I believed you! I just kept putting it off....
__________________
Beemer is offline   Reply With Quote
Old 10-30-2015, 05:57 PM   #9
W4rMach1ne
 
Drives: 2011 Camaro LT1
Join Date: Apr 2015
Location: Florida, United States
Posts: 337
Nice. Post it in the under the hood forum so we can all see.
W4rMach1ne is offline   Reply With Quote
Old 10-31-2015, 11:15 AM   #10
Beemer
"Red Rocket"
 
Beemer's Avatar
 
Drives: 2010 Camaro 1LT
Join Date: Aug 2009
Location: Morgan Mill, Texas
Posts: 347
Quote:
Originally Posted by W4rMach1ne View Post
Nice. Post it in the under the hood forum so we can all see.
What is the "under the hood" forum?

I probably won't post a picture. I mean- it looks like all the others that have been installed over the last 6 years.
__________________
Beemer is offline   Reply With Quote
Old 11-01-2015, 07:58 AM   #11
W4rMach1ne
 
Drives: 2011 Camaro LT1
Join Date: Apr 2015
Location: Florida, United States
Posts: 337
http://www.camaro5.com/forums/showth...=426093&page=2
W4rMach1ne is offline   Reply With Quote
Old 11-01-2015, 08:04 AM   #12
richard200593

 
richard200593's Avatar
 
Drives: 2012 45th Anniversary RS
Join Date: May 2012
Location: California
Posts: 872
I literally had the exact same thing happen... Busted one of the clips checking the stock filter, decided it was the perfect excuse to buy a cai from cold air inductions, just not the powder coated one
__________________
*Performance:
mrt v2.0 exhaust/CAI Intake
*Cosmetic:
Zl1 factory Reproduction wheels
Bmr 1.2/1.4 springs/Oracle plasma drl lights, footwell ambient lighting, 45th Gobo lights
*Audio:
Memphis pr600 amp/Fosgate 12" t0 sub/******** stealth box
richard200593 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:23 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.