Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Gen5DIY
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro ZL1 Forum - ZL1 Specific Topics > Engine | Exhaust | Bolt-On | Drivetrain Modifications


Reply
 
Thread Tools
Old 10-19-2018, 02:49 AM   #1
newz
 
Drives: 2013 ZL1
Join Date: Dec 2017
Location: ohio
Posts: 69
Clutch pedal dropping.

Well it seems like I now have a clutch pedal that dropped to the floor overnight.
I can pull it up and pump the pedal a couple of times and the clutch works fine.

Last time the problem was a clutch pedal that went to the floor when I was shifting. Had dealer bleed/flush the slave and all seemed to be well. I seem to remember a tsb that covered this clutch pedal problem but I have not found it yet. If the problem requires a clutch pedal replacement the dealer says clutch and hydraulic problems are not covered by any warranty. Any advice wold be appreciated.
newz is offline   Reply With Quote
Old 10-19-2018, 09:33 AM   #2
frankwjr

 
frankwjr's Avatar
 
Drives: 2010 SS 2SS M6
Join Date: Aug 2016
Location: Smithsburg, Md.
Posts: 2,186
have a look at your brake/clutch fluid...dirty? then do this first http://www.rangeracceleration.com/Clutch_Care.html
should take care of the prob easy peasy...plus it's cheap. Upgrade to DOT 4(I use SYN DOT 3/4) while your are at it.


Then once the fluid is nice a clean you can do a 4 corner brake bleed. Pull about an oz from ea bleeder and read up on proper brake bleed procedure.


good luck!


peace
__________________
2010 SS 2SS M6 - Tune by RDP dynoSteve!(Woot) - Daily Driver - 127K! - All work by me...
frankwjr is offline   Reply With Quote
Old 10-19-2018, 03:05 PM   #3
Boother
 
Drives: 14 ZL1
Join Date: Mar 2014
Location: Calgary
Posts: 145
From your previous thread, did you replace the reservoir seal with the original style with slit?

In my case, this had nothing to do with fluid quality or cleanliness. It was a Master cylinder failure. https://www.camaro5.com/forums/showthread.php?t=528826

GM has replaced my clutch pedal assembly (the master cylinder is part of the pedal assembly) twice now for the same issue. The master cylinder is covered under bumper to bumper warranty, but that is expired on your car.

For some reason, the MC is not sold separately, so you have 2 options. Buy the entire pedal assembly or try out the newly released Tick Master cylinder. http://www.tickperformance.com/tick-...ontiac-g8-gxp/
Boother is offline   Reply With Quote
Old 10-19-2018, 07:26 PM   #4
newz
 
Drives: 2013 ZL1
Join Date: Dec 2017
Location: ohio
Posts: 69
Well weird and maybe good news. The pedal went to the floor twice today and stayed about a inch from the floor while shifting. Fortunately I was able to hook the side of the pedal the first time and it popped back up,pumped twice and made it has far has Krogers parking lot. Then it happened again after dropping down to 1st to pull into the parking lot. Left it there and and coasted to a clear area and left it in first and turned the car off to come to a stop. Took a photo with the pedal down and a short video showing me pumping the pedal after pulling it back up by hand for the dealer.

Hate to think both problems happened at the same time.
Yes the fluid was completely removed by the dealer and replaced with new SRF fluid a few weeks ago and both systems(clutch and brakes) were flushed at the same time. Between the twice a season flushes by the dealer and my bleeding after each track day the fluid has never looked dirty. I have three seasons of track seasons on the ZL1 and a couple years with 2010 2SS. Have always followed the above fluid flush and bleed schedule. Boother I did purchase the cap with the slit.

Last edited by newz; 10-19-2018 at 11:46 PM.
newz is offline   Reply With Quote
Old 10-19-2018, 08:14 PM   #5
Boother
 
Drives: 14 ZL1
Join Date: Mar 2014
Location: Calgary
Posts: 145
Found the service docs when I got home today. Service bulletin is PI0486C. Note this number may be different for your dealer as I am in Canada.
Attached Images
 
Boother is offline   Reply With Quote
Old 10-19-2018, 11:48 PM   #6
newz
 
Drives: 2013 ZL1
Join Date: Dec 2017
Location: ohio
Posts: 69
Boother thanks for the info. Will print it out and take it to the dealer with me.
newz is offline   Reply With Quote
Old 11-03-2018, 01:56 AM   #7
newz
 
Drives: 2013 ZL1
Join Date: Dec 2017
Location: ohio
Posts: 69
Boother I got the car back from the dealer today. They did the same repairs you had done.
Also thanks for the document you included in your post. Showed it to the service manager and received a 50 percent discount on the entire bill. I guess only time will tell if this is the cure.
newz is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:09 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.