Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
sjm autoprod
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LLT Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 01-30-2018, 05:14 AM   #1
Slow_6banger
 
Drives: V6 camaro with straight pipes
Join Date: Apr 2017
Location: Las Vegas, NV
Posts: 8
Reduced Engine Power/New Engine Issues

So I blew the original 3.6 in my camaro and replaced it with a cherry 84k mile motor from the same year, but after install and first start (which was very rough maybe from 3-4 month old gas) I came across a “Reduced Engine Power” message on my dash and a check engine for a pedal position, a throttle position, fuel regulator, and idle position- which one of these codes could have tripped the REP because ATM I’m shit outta luck and I have no idea where to go from here except replacing the throttle body and checking my regulator?
Slow_6banger is offline   Reply With Quote
Old 01-30-2018, 05:16 AM   #2
Slow_6banger
 
Drives: V6 camaro with straight pipes
Join Date: Apr 2017
Location: Las Vegas, NV
Posts: 8
Ohh and yes I did this myself in a garage with some tools and a bit of know how
Slow_6banger is offline   Reply With Quote
Old 02-19-2018, 11:39 AM   #3
djrasras
 
djrasras's Avatar
 
Drives: 2010 2LT Bumblebee
Join Date: Apr 2013
Location: Maryland
Posts: 588
My "Reduce Engine Power, Service Stabilitrak" code was due to using the Vitesse Throttle Controller, and then later again because of the steering wheel adjustment. I would check these and definitely the battery terminals and actual throttle body. I think I fixed this problem another time by replacing my intake filter and chancing the oil (it sucked in some water on a really rainy day).
__________________
AirLift Air Suspension, Stainless Works Long Tube Headers + Hi-Flo Cats, Resonated X-Pipe, MRT V2 Mufflers, VMAX Ice-olator and Ported Throttle Body, Barton Short Throw Shifter, CAI Intake + Air Scoop
djrasras is offline   Reply With Quote
Old 02-19-2018, 03:32 PM   #4
GreaseMonkey
 
GreaseMonkey's Avatar
 
Drives: 2011 2LT/RS Camaro
Join Date: Jul 2013
Location: Pflugerville,Texas / Houston,Texas
Posts: 159
Quote:
Originally Posted by Slow_6banger View Post
So I blew the original 3.6 in my camaro and replaced it with a cherry 84k mile motor from the same year, but after install and first start (which was very rough maybe from 3-4 month old gas) I came across a “Reduced Engine Power” message on my dash and a check engine for a pedal position, a throttle position, fuel regulator, and idle position- which one of these codes could have tripped the REP because ATM I’m shit outta luck and I have no idea where to go from here except replacing the throttle body and checking my regulator?
If you have a throttle controller try taking it off (Ideal) or the quick way which worked in my situation was do the relearn process of it.
GreaseMonkey is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:41 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.