Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Member Car Journals


Reply
 
Thread Tools
Old 08-07-2020, 08:25 PM   #85
Vicster
 
Vicster's Avatar
 
Drives: 13' ZL1
Join Date: Jan 2013
Location: Seattle
Posts: 268
Hello

Quote:
Originally Posted by FasNuf View Post
Thanks for the reply. I had a similar misfire situation and still do to some extent. I changed my #4 plug and it helped a ton but I think I need to tighten my gap. I'm currently at .039" @ 14.5 psi boost. I bet if I tighten them up like you did, it'll help.
No issues with the 10% coil dwell?
Gap is working great, no issues at all with adding coil dwell time.Here is a pic of the changes I made.
Attached Images
  
Vicster is offline   Reply With Quote
Old 08-07-2020, 08:46 PM   #86
FasNuf
 
FasNuf's Avatar
 
Drives: 2014 Camaro ZL1
Join Date: Jul 2019
Location: Salem Oregon
Posts: 522
Awesome! Thanks Vic
__________________
FasNuf is online now   Reply With Quote
Old 08-07-2020, 09:01 PM   #87
Vicster
 
Vicster's Avatar
 
Drives: 13' ZL1
Join Date: Jan 2013
Location: Seattle
Posts: 268
Wink You are welcome

Quote:
Originally Posted by FasNuf View Post
Awesome! Thanks Vic
No Problem anytime!
Vicster is offline   Reply With Quote
Old 08-08-2020, 08:03 AM   #88
brick59
Sucker Punch
 
brick59's Avatar
 
Drives: 2013 Black ZL1, 2007 Silverado LTZ
Join Date: Jul 2014
Location: N.E. Ohio
Posts: 210
Quote:
Originally Posted by FasNuf View Post
Thanks for the reply. I had a similar misfire situation and still do to some extent. I changed my #4 plug and it helped a ton but I think I need to tighten my gap. I'm currently at .039" @ 14.5 psi boost. I bet if I tighten them up like you did, it'll help.
No issues with the 10% coil dwell?
As your boost go's up your gap needs to come down I'm at 14 to 15 psi and run mine at .030 with no misfires my tuner said I could go down to .028 to .026 if it starts to misfire but so far no problem's. I think I read somewhere in ttshovel's build thread he's down to to .018 to .020 gap with high 20s to low 30s boost. Hope this helps you guys.
__________________
9.84 @ 142.5 MPH, Mass heads, Cam Motion LLR cam, Morel tie bar lifters, Crower roller rockers, Ported blower and snout, NW102 TB, 2.5/9.1 Pulleys, ID 1300, Fore, DSX, E85, Meth Injection, Chiller, Roto-Fab CAI, Kooks 2" Headers, H/F Cats, Corsa, Circle D, RPM, BMR, Carlyle Racing 15" conversion kit.
brick59 is offline   Reply With Quote
Old 08-09-2020, 02:50 PM   #89
Vicster
 
Vicster's Avatar
 
Drives: 13' ZL1
Join Date: Jan 2013
Location: Seattle
Posts: 268
Talking I am FINISHED!

I finally finished every thing I want to do to my car, I may have to repaint some items with Plasti-Dip as it bubbled on me. All I have to do now is a dyno-tune. I will try to schedule it, do not know if I can get it done with the (Moron Virus) lock down going on.
Now it just needs a good bath!
Attached Images
          

Last edited by Vicster; 08-09-2020 at 03:01 PM.
Vicster is offline   Reply With Quote
Old 08-09-2020, 09:10 PM   #90
Vicster
 
Vicster's Avatar
 
Drives: 13' ZL1
Join Date: Jan 2013
Location: Seattle
Posts: 268
Wink Test Drive

Quote:
Originally Posted by Vicster View Post
Thanks for asking, The only thing that is suppose to change is the hill hold assist. I have the front tires off right now as I am painting them with plasti-dip. Will post if I notice any thing else different.
Hello,
So Far after first drive the only thing that has changed is the hill assist is gone.
Vicster is offline   Reply With Quote
Old 08-09-2020, 10:26 PM   #91
FasNuf
 
FasNuf's Avatar
 
Drives: 2014 Camaro ZL1
Join Date: Jul 2019
Location: Salem Oregon
Posts: 522
Quote:
Originally Posted by brick59 View Post
As your boost go's up your gap needs to come down I'm at 14 to 15 psi and run mine at .030 with no misfires my tuner said I could go down to .028 to .026 if it starts to misfire but so far no problem's. I think I read somewhere in ttshovel's build thread he's down to to .018 to .020 gap with high 20s to low 30s boost. Hope this helps you guys.
Thanks, I’ll give it a shot. I occasionally get a feeling like the power is breaking up near redline. I logged but never saw what was actually going on. I hate removing my plugs. I always seem to break at least one.
__________________
FasNuf is online now   Reply With Quote
Old 08-10-2020, 08:52 AM   #92
Vicster
 
Vicster's Avatar
 
Drives: 13' ZL1
Join Date: Jan 2013
Location: Seattle
Posts: 268
Wink I feel you pain

Quote:
Originally Posted by FasNuf View Post
Thanks, I’ll give it a shot. I occasionally get a feeling like the power is breaking up near redline. I logged but never saw what was actually going on. I hate removing my plugs. I always seem to break at least one.
I have the same problem, it is a tight squeeze, but not as bad as my 1994 Z28 I use to have, you had to do the plugs from under the car...

Last edited by Vicster; 08-14-2020 at 09:48 AM.
Vicster is offline   Reply With Quote
Old 08-13-2020, 12:13 AM   #93
fireman1153
 
Drives: 2010 Camaro SS
Join Date: Feb 2018
Location: Panama City, FL
Posts: 52
I hate to interrupt such an awesome thread just to ask a question but where did you get your 6 point roll bar from and can the cross bar be removed easily for daily driving? I’m in the market for one since my last power upgrade but don’t want to lose the capability of my kids riding in the back seat when I’m not heading to the track. Thanks man.
fireman1153 is offline   Reply With Quote
Old 08-14-2020, 09:47 AM   #94
Vicster
 
Vicster's Avatar
 
Drives: 13' ZL1
Join Date: Jan 2013
Location: Seattle
Posts: 268
Wink No Problem

Quote:
Originally Posted by fireman1153 View Post
I hate to interrupt such an awesome thread just to ask a question but where did you get your 6 point roll bar from and can the cross bar be removed easily for daily driving? Iím in the market for one since my last power upgrade but donít want to lose the capability of my kids riding in the back seat when Iím not heading to the track. Thanks man.
Hello,
You are not interrupting, one of the reasons I posted all of this is to help others. The rollbar is from RPM. It does have removable bars both the diagonal (SCCA) bar and the cross bar (that the belts attach to). I have heard that RPM no longer makes this type of rollbar, but check with them just to be sure. Here is the web address.

http://rpmrollbar.com/

I would still not feel comfortable with anyone sitting in the back seat as they could impact the upper bar in an accident. Also the seat back no longer drops flat as it hits the rear support bars.

I made an error cutting the holes in the side panels, I checked everything 3 times before drilling the holes, but some how managed to have them 1" or so to far fwd.

If you want something removable you can try something like this. It is relatively easy to install and remove for shoulder harnesses. I still use the lap mount attached points as pictured. 2010+ Camaro Brey-Krause Inside Lap Belt Mount Kit and the Brey Krause Model R-9003 Short Harness Mount Kit. I used a harness eye bolt for the anti dive strap, I cannot remember if there is a hole just fwd of the front seat power connection or if I drilled it. It was easy to install a washer (thick fender washer) on both sides (top washer has the sides ground off to fit in the recess) and tighten the nut (nylock nut so it does not vibrate off), found a pic sort of... You can see that the other bars are off when we installed the rollbar.

https://www.braumracing.com/product/...o-harness-bar/

It is what I use to use fire bottle was attached to it, I have the red one that I am selling for $200. I just need to post it on ebay...

Hope this helps, it is just my wife and I so losing the back seat was no big deal...
Attached Images
      

Last edited by Vicster; 08-15-2020 at 08:02 PM.
Vicster is offline   Reply With Quote
Old 08-14-2020, 05:29 PM   #95
fireman1153
 
Drives: 2010 Camaro SS
Join Date: Feb 2018
Location: Panama City, FL
Posts: 52
I actually have a harness bar already but have been looking into the roll bar since I’m now making just under 1k rwhp. I really need the roll bar at the track. Thank you for your quick response man and I will check into the options you provided.
fireman1153 is offline   Reply With Quote
Old 08-15-2020, 08:00 PM   #96
Vicster
 
Vicster's Avatar
 
Drives: 13' ZL1
Join Date: Jan 2013
Location: Seattle
Posts: 268
Wink No Problem

Quote:
Originally Posted by fireman1153 View Post
I actually have a harness bar already but have been looking into the roll bar since I’m now making just under 1k rwhp. I really need the roll bar at the track. Thank you for your quick response man and I will check into the options you provided.
You are welcome, good luck! If you are able to get the rollbar with the removable bar get it with one seat belt mount per seat, the outboard one on the double is really hard to use, that is why I made a connecting bar for them.
Attached Images
 

Last edited by Vicster; 08-15-2020 at 08:13 PM.
Vicster is offline   Reply With Quote
Old 08-15-2020, 08:24 PM   #97
Vicster
 
Vicster's Avatar
 
Drives: 13' ZL1
Join Date: Jan 2013
Location: Seattle
Posts: 268
HUD

So I broke down and ordered a color HUD, should have done it before I put the interior back in, but came across a great deal. Oh well remove the interior one more time, this time the whole dash has to come out. Read up on it should take 1 day to swap it out...
Attached Images
 
Vicster is offline   Reply With Quote
Old 08-16-2020, 12:53 PM   #98
fireman1153
 
Drives: 2010 Camaro SS
Join Date: Feb 2018
Location: Panama City, FL
Posts: 52
Quote:
Originally Posted by Vicster View Post
You are welcome, good luck! If you are able to get the rollbar with the removable bar get it with one seat belt mount per seat, the outboard one on the double is really hard to use, that is why I made a connecting bar for them.
Thanks man. I really appreciate your help.
fireman1153 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:32 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.