Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
TireRack
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum


Reply
 
Thread Tools
Old 02-14-2014, 06:08 PM   #1
ben3350
 
ben3350's Avatar
 
Drives: 2010 Camaro 2LT ABM
Join Date: Jun 2012
Location: Atlanta
Posts: 485
Trying to decide between the Pioneer Avic-z150bh and Pioneer AVH-x5600bhs

From what I understand both of these headunits are newer touchscreen headunits from Pioneer, although the 5600bhs just came out, and the z150bh came out around this time last year.

Does anyone have any experience with either head unit? Most likely pairing it with a scosche kit (metra is too ugly and alpine is too hard to find).

The z150bh has navigation included, while the 5600 doesn't have it but it is a good bit cheaper and a newer model. Navigation is preferred, but if I can run it through the 5600 without a ton of hassle, then it may be worth it to me while saving money.

The 5600 I can find for around 4-500. The z150bh I can find for around 8-850. One thing of note is that these are online prices. Since the 5600 is new, it's going to be the same price almost everywhere, whereas online the z150bh can be found for cheaper online. But going through a local audio dealer is much less of a hassle then buying a discounted z150bh in case anything doesn't work. At a dealer I can just replace it right there.

So if anyone has any advice for this or has any experience with these head units please let me know.
__________________
Ark N-II catback exhaust, ZL1 bumper, JL C5 comps, JL 10w7, JL 500/1v2, JL 300/4v2
ben3350 is offline   Reply With Quote
Old 02-14-2014, 08:33 PM   #2
Caddyroger

 
Caddyroger's Avatar
 
Drives: 2011 RJT Camaro LT2 RS auto shift
Join Date: Dec 2011
Location: Washington state
Posts: 1,861
I had the Z-140 bh installed in my car. It worked good with Scosche kit. Every thing worked very well with no problems between the two.
__________________
Caddy
Caddyroger is offline   Reply With Quote
Old 02-15-2014, 12:59 AM   #3
ben3350
 
ben3350's Avatar
 
Drives: 2010 Camaro 2LT ABM
Join Date: Jun 2012
Location: Atlanta
Posts: 485
Quote:
Originally Posted by Caddyroger View Post
I had the Z-140 bh installed in my car. It worked good with Scosche kit. Every thing worked very well with no problems between the two.
I'm guessing the z140 is pretty much the same unit just one year behind right? how was the navigation? since that's pretty much the deciding factor between the 2 HU's I go for.
__________________
Ark N-II catback exhaust, ZL1 bumper, JL C5 comps, JL 10w7, JL 500/1v2, JL 300/4v2
ben3350 is offline   Reply With Quote
Old 02-15-2014, 01:13 AM   #4
Caddyroger

 
Caddyroger's Avatar
 
Drives: 2011 RJT Camaro LT2 RS auto shift
Join Date: Dec 2011
Location: Washington state
Posts: 1,861
Quote:
Originally Posted by ben3350 View Post
I'm guessing the z140 is pretty much the same unit just one year behind right? how was the navigation? since that's pretty much the deciding factor between the 2 HU's I go for.
Yes it was the year older unit. The navigation was pretty good to me but that was the first time that I ever used one.
__________________
Caddy
Caddyroger is offline   Reply With Quote
Old 02-15-2014, 02:32 AM   #5
ben3350
 
ben3350's Avatar
 
Drives: 2010 Camaro 2LT ABM
Join Date: Jun 2012
Location: Atlanta
Posts: 485
you said you "had" it. why did you get rid of it and what do you have now if you don't mind me asking?
__________________
Ark N-II catback exhaust, ZL1 bumper, JL C5 comps, JL 10w7, JL 500/1v2, JL 300/4v2
ben3350 is offline   Reply With Quote
Old 02-15-2014, 02:23 PM   #6
Caddyroger

 
Caddyroger's Avatar
 
Drives: 2011 RJT Camaro LT2 RS auto shift
Join Date: Dec 2011
Location: Washington state
Posts: 1,861
Quote:
Originally Posted by ben3350 View Post
you said you "had" it. why did you get rid of it and what do you have now if you don't mind me asking?

I have a Kenwood DNX860hd unit now. The is a company that was integrating the gauges into the radio but it would only work on certain model of Kenwoods. Now afer the fact the company is not planning getting it to work with GM cars so money down the drain. That was about the only reason in the change.
__________________
Caddy
Caddyroger is offline   Reply With Quote
Old 02-16-2014, 09:43 AM   #7
Icefsh
 
Icefsh's Avatar
 
Drives: CGM 2LT/RS M6
Join Date: Jul 2009
Location: Littleton, CO.
Posts: 194
I think the 5500 is the 2013 model and can be found for cheaper. Don't think Pioneer has done many upgrades, maybe one or two to the 5600. You can buy one through Cruchfield with the PAC adaptor and dash kit for under $500. I installed one in my 2012 Silverado and really enjoy it. You can buy a separate cable to get nav from your phone. The cables are kind of expensive but can be found cheaper on ebay, amazon.
Icefsh is offline   Reply With Quote
Old 02-16-2014, 10:32 AM   #8
Icefsh
 
Icefsh's Avatar
 
Drives: CGM 2LT/RS M6
Join Date: Jul 2009
Location: Littleton, CO.
Posts: 194
Sorry the 5500 has been discontinued at Crutchfield.
Icefsh is offline   Reply With Quote
Old 02-16-2014, 02:31 PM   #9
dnkygirl
 
dnkygirl's Avatar
 
Drives: 2011 Camaro 2LT/RS
Join Date: Dec 2012
Location: Dallas
Posts: 31
Quote:
Originally Posted by Caddyroger View Post
I have a Kenwood DNX860hd unit now. The is a company that was integrating the gauges into the radio but it would only work on certain model of Kenwoods. Now afer the fact the company is not planning getting it to work with GM cars so money down the drain. That was about the only reason in the change.
I looked at the Kenwood DNX890 unit and was going to purchase it for that fact as well, but it looks like there's something going on with the GM idatalink option MAESTRO RR module. It looks like a lot of 3 party vendors hate the Camaro's wiring... This is the first time i've ever seen a popular car not get many options. It's like the plague or something. GM really needs to rectify this for us. They need to confess that the radio option was a bad idea in the Camaro 2010-2014. Stop trying to dazzle us with bad electronics like the Mylink in the new Camaro's. Give us control of our radios again.. what's is really going on here...
dnkygirl is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:15 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.