Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Vararam
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 04-19-2018, 08:52 PM   #99
SannerRacing
 
SannerRacing's Avatar
 
Drives: 2010 1SS RS IOM
Join Date: Sep 2009
Location: Inland Empire
Posts: 249
Quote:
Originally Posted by BiggFoot View Post
Sorry man. Keeping these machines going seems to be a full time job and expensive.

Did the bolt damage your trans or was it just causing noise?

Did you ever get another dyno past 7psi of boost? If so, then I missed it.
Lol I hear that! And I'm not sure what let go in the trans and why. All I know is a brand new trans should go more than 50miles. And no on the dyno was working on the boost controller when this happened. So as soon as I get it up and running again I'll get back on the fun stuff.
__________________

Forged LS3 416ci, Maggie TVS2300 @ 13lbs boost, McCleod twin disc clutch, GForce 1320 nine-inch 389 gear ratio, Hurst line-lock, 750 whp 700 wtq
SannerRacing is offline   Reply With Quote
Old 04-19-2018, 08:54 PM   #100
SannerRacing
 
SannerRacing's Avatar
 
Drives: 2010 1SS RS IOM
Join Date: Sep 2009
Location: Inland Empire
Posts: 249
Quote:
Originally Posted by Cam 427 View Post
Thanks. I have blue exhaust smoke shortly after start up that goes away after warm up. Precision Turbo recommends better crankcase venting. It's worth a try, I guess...

Sorry about your transmission. Interesting to see what they find.
Do you have a oil regulator for the oil going to your turbos? Cause that helped mine a ton.
__________________

Forged LS3 416ci, Maggie TVS2300 @ 13lbs boost, McCleod twin disc clutch, GForce 1320 nine-inch 389 gear ratio, Hurst line-lock, 750 whp 700 wtq
SannerRacing is offline   Reply With Quote
Old 04-24-2018, 05:01 PM   #101
Cam 427
 
Cam 427's Avatar
 
Drives: 2010 2SS
Join Date: Apr 2010
Location: Washington
Posts: 676
Quote:
Originally Posted by SannerRacing View Post
Do you have a oil regulator for the oil going to your turbos? Cause that helped mine a ton.
I don't have a regulator but measured the amount of oil that drains in the return lines to the pan and it came to about half of what was considered excessive. I think it was 4.5-5 ounces in 30 seconds per drain line and the manufacturer stated the max was 10-12.

I saw the oil regulator in one of your photos ( it had what looks to be oil lines to it) and I may try it. Who makes it?
Cam 427 is offline   Reply With Quote
Old 04-25-2018, 01:46 AM   #102
SannerRacing
 
SannerRacing's Avatar
 
Drives: 2010 1SS RS IOM
Join Date: Sep 2009
Location: Inland Empire
Posts: 249
Quote:
Originally Posted by Cam 427 View Post
I don't have a regulator but measured the amount of oil that drains in the return lines to the pan and it came to about half of what was considered excessive. I think it was 4.5-5 ounces in 30 seconds per drain line and the manufacturer stated the max was 10-12.

I saw the oil regulator in one of your photos ( it had what looks to be oil lines to it) and I may try it. Who makes it?
I started by finding out how much psi these turbos needed witch was 40. The guys at turbo smart had the right one. If you go that route make sure you don't do what I did. It didn't come with instructions and I thought it was
Like a fuel regulator. I found out the hard way it's not. Hope this helps,it definitely helped with my set up.
__________________

Forged LS3 416ci, Maggie TVS2300 @ 13lbs boost, McCleod twin disc clutch, GForce 1320 nine-inch 389 gear ratio, Hurst line-lock, 750 whp 700 wtq
SannerRacing is offline   Reply With Quote
Old 04-26-2018, 08:50 PM   #103
Cam 427
 
Cam 427's Avatar
 
Drives: 2010 2SS
Join Date: Apr 2010
Location: Washington
Posts: 676
Quote:
Originally Posted by SannerRacing View Post
I started by finding out how much psi these turbos needed witch was 40. The guys at turbo smart had the right one. If you go that route make sure you don't do what I did. It didn't come with instructions and I thought it was
Like a fuel regulator. I found out the hard way it's not. Hope this helps,it definitely helped with my set up.
Thanks for the info. I'll give it a shot.
Cam 427 is offline   Reply With Quote
Old 05-24-2018, 01:08 PM   #104
SannerRacing
 
SannerRacing's Avatar
 
Drives: 2010 1SS RS IOM
Join Date: Sep 2009
Location: Inland Empire
Posts: 249
Injector harness

Here's a pic of the new injector harnesses. Way better than the factory one! Trans is back in so soon will hit the track and get some numbers.
Attached Images
 
__________________

Forged LS3 416ci, Maggie TVS2300 @ 13lbs boost, McCleod twin disc clutch, GForce 1320 nine-inch 389 gear ratio, Hurst line-lock, 750 whp 700 wtq
SannerRacing is offline   Reply With Quote
Old 05-24-2018, 01:11 PM   #105
SannerRacing
 
SannerRacing's Avatar
 
Drives: 2010 1SS RS IOM
Join Date: Sep 2009
Location: Inland Empire
Posts: 249
It also unplugs so you can take the manifold off without removing all the injector wires.
Attached Images
 
__________________

Forged LS3 416ci, Maggie TVS2300 @ 13lbs boost, McCleod twin disc clutch, GForce 1320 nine-inch 389 gear ratio, Hurst line-lock, 750 whp 700 wtq
SannerRacing is offline   Reply With Quote
Old 05-24-2018, 01:15 PM   #106
RealQuick
 
Drives: 2010 Camaro 2SS M6 - Intake/Exhaust
Join Date: Sep 2014
Location: Bridgewater
Posts: 540
Killer! Nice work!
RealQuick is offline   Reply With Quote
Old 06-07-2018, 04:24 PM   #107
SannerRacing
 
SannerRacing's Avatar
 
Drives: 2010 1SS RS IOM
Join Date: Sep 2009
Location: Inland Empire
Posts: 249
Here's the beef!

Ok well had a great night,so on 7lbs springs only no boost controller yet. A very inconsistent rookie trans break operator and with very poor weight transfer. Basically what I'm getting at is there's a LOT more in this car with out more boost. And let me tell you 3rd gear is where it's at wow! After the 9.91 run I had to slow down and work on my 1/8 mile cause I only have enough cage for 9.99.
Attached Images
 
__________________

Forged LS3 416ci, Maggie TVS2300 @ 13lbs boost, McCleod twin disc clutch, GForce 1320 nine-inch 389 gear ratio, Hurst line-lock, 750 whp 700 wtq
SannerRacing is offline   Reply With Quote
Old 06-07-2018, 08:37 PM   #108
RealQuick
 
Drives: 2010 Camaro 2SS M6 - Intake/Exhaust
Join Date: Sep 2014
Location: Bridgewater
Posts: 540
Wow! Nicely done!!!!
RealQuick is offline   Reply With Quote
Old 06-08-2018, 08:20 AM   #109
acammer
Back in the game
 
acammer's Avatar
 
Drives: 2011 Camaro 2SS SGM
Join Date: Jul 2016
Location: Weedsport, NY
Posts: 1,575
Dang - that's hustling man. Imagine what that'll do once you have the launch dialed and you add some boost control to really back-half like a beast! Nice.
__________________
2011 2SS SGM - Cold Air Inductions CAI, New Era PTB, GPI Rod-Mod and ported LS3 intake, BTR Platinum springs, GPI SS3 cam, American Racing Long Tube Headers 1.875", X-pipe, high flow cats, cutouts behind the axle. 25% under-drive pulley, 169*F T-stat, EE catch can, Ideal Garage clutch master cylinder and reservoir, Tick-Shift billet throwout support, Speedbleeder, Motive 4.10 gears, LPW Differential Cover, BMR Pro diff bushings, Pegasus Solid rear sub-frame bushings, 305/45/18 NT05R. Speedhut OBDII shift light. Tuned at New Age Hotrods - 497rwhp.
Selling an HPT Setup cheap? Message me!
acammer is offline   Reply With Quote
Old 06-09-2018, 10:39 AM   #110
SannerRacing
 
SannerRacing's Avatar
 
Drives: 2010 1SS RS IOM
Join Date: Sep 2009
Location: Inland Empire
Posts: 249
Quote:
Originally Posted by RealQuick View Post
Wow! Nicely done!!!!
Thanks and I'm keeping my eye on your build soon you'll have the same issue of how do I get it all to the ground!
__________________

Forged LS3 416ci, Maggie TVS2300 @ 13lbs boost, McCleod twin disc clutch, GForce 1320 nine-inch 389 gear ratio, Hurst line-lock, 750 whp 700 wtq
SannerRacing is offline   Reply With Quote
Old 06-09-2018, 10:42 AM   #111
SannerRacing
 
SannerRacing's Avatar
 
Drives: 2010 1SS RS IOM
Join Date: Sep 2009
Location: Inland Empire
Posts: 249
Quote:
Originally Posted by acammer View Post
Dang - that's hustling man. Imagine what that'll do once you have the launch dialed and you add some boost control to really back-half like a beast! Nice.
Thanks and yes definitely need work on launching and I know I could have put more to it in 3rd for sure. And probably a gear change coming soon.
__________________

Forged LS3 416ci, Maggie TVS2300 @ 13lbs boost, McCleod twin disc clutch, GForce 1320 nine-inch 389 gear ratio, Hurst line-lock, 750 whp 700 wtq
SannerRacing is offline   Reply With Quote
Old 06-14-2018, 02:22 PM   #112
2010SSRSM6


 
2010SSRSM6's Avatar
 
Drives: My wife crazy with my C5 usage.
Join Date: Apr 2009
Location: DFW area
Posts: 6,559
Quote:
Originally Posted by SannerRacing View Post
Thanks and yes definitely need work on launching and I know I could have put more to it in 3rd for sure. And probably a gear change coming soon.


What’s wrong with 3.89’s? LMAO


Sent from my iPhone using Tapatalk
__________________
UNDER CONSTRUCTION......again......
2010SSRSM6 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:00 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.