Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Bigwormgraphix
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > Camaro Z/28 Forum - Z/28 Specific Topics


Reply
 
Thread Tools
Old 09-04-2019, 04:27 PM   #1
2SSRS@Gen5diy
 
2SSRS@Gen5diy's Avatar
 
Drives: To many to list
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 15,575
LS7

Picked up a hurt LS7 Out of a Z/28 dont know if the block is salvageable or not, cam is stock in the block do to a lifter not coming out, will get it on a stand soon and see how bad it is, hope i can save the block.
2SSRS@Gen5diy is offline   Reply With Quote
Old 09-04-2019, 08:29 PM   #2
Gbland60
 
Gbland60's Avatar
 
Drives: 2015 z28 Black w/ac #645
Join Date: Jan 2017
Location: Southeast Texas
Posts: 225
When you say hurt you mean like what mains, rods, dropped valve, broken cam ?
Gbland60 is offline   Reply With Quote
Old 09-04-2019, 08:35 PM   #3
69L48Z27
 
69L48Z27's Avatar
 
Drives: 2015 Z/28; 1969 Camaro SS
Join Date: Nov 2015
Location: York, PA
Posts: 669
Post what VIN is on the engine if you don’t mind. See if it belongs to one of the cars in the salvage thread.
69L48Z27 is offline   Reply With Quote
Old 09-04-2019, 11:36 PM   #4
2SSRS@Gen5diy
 
2SSRS@Gen5diy's Avatar
 
Drives: To many to list
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 15,575
Quote:
Originally Posted by Gbland60 View Post
When you say hurt you mean like what mains, rods, dropped valve, broken cam ?
No more like a roller lifter, that needs to come out and will not.

Quote:
Originally Posted by 69L48Z27 View Post
Post what VIN is on the engine if you don’t mind. See if it belongs to one of the cars in the salvage thread.
It's not out of a salvaged car, I know the car it came out of, and if the owner does not want me to say then I will not.

It may need a block when I get some time I will find out.
2SSRS@Gen5diy is offline   Reply With Quote
Old 09-05-2019, 02:58 PM   #5
2SSRS@Gen5diy
 
2SSRS@Gen5diy's Avatar
 
Drives: To many to list
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 15,575
So two sets of two lifters are stock, one goes up far so i can move the cam forward but the second set will not move up for the cam to move forward, time for the BMH, ned to get that lifter up out of the way.
2SSRS@Gen5diy is offline   Reply With Quote
Old 09-05-2019, 05:04 PM   #6
Gbland60
 
Gbland60's Avatar
 
Drives: 2015 z28 Black w/ac #645
Join Date: Jan 2017
Location: Southeast Texas
Posts: 225
Got ya. Maybe you can sleeve the bores once its out. IDK but good luck on the project build. Sounds like fun
Gbland60 is offline   Reply With Quote
Old 09-10-2019, 03:16 PM   #7
Russell James


 
Russell James's Avatar
 
Drives: '15 SS 1LE, '69 Z28 drag car
Join Date: Dec 2009
Location: Mich
Posts: 4,415
Cams fracture pretty easy with sharp blows. Might be able to get a big punch in there are break the cam up. If you can get the cam pieces out, shove the stuck lifters out the bottom. I got lucky doing that once with a BBC that had mushroom'd out a lifter. Then had the lifter bores bronze bushed.
Russell James is offline   Reply With Quote
Old 09-27-2019, 04:12 PM   #8
2SSRS@Gen5diy
 
2SSRS@Gen5diy's Avatar
 
Drives: To many to list
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 15,575
Today we worked on the LS7 cut off the lifter ( there comp lifters and come as a set of 2) and where able to remove the cam, that was not fun, needs cam bearings there done, needs Cam and lifters to, now to get the block redone.
2SSRS@Gen5diy is offline   Reply With Quote
Old 09-28-2019, 03:16 PM   #9
2SSRS@Gen5diy
 
2SSRS@Gen5diy's Avatar
 
Drives: To many to list
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 15,575
Today we pulled the pan and windage tray, think this motor had some oiling problums, front of crank is blue like it got hot, rear is fine, will post pic's later this coming week, got to talk with the prior owner.
2SSRS@Gen5diy is offline   Reply With Quote
Old 09-29-2019, 08:02 AM   #10
ronchev
 
ronchev's Avatar
 
Drives: 14' Red Z/28 #336
Join Date: Mar 2016
Location: Northen Indiana
Posts: 208
Quote:
Originally Posted by 2SSRS@Gen5diy View Post
Today we pulled the pan and windage tray, think this motor had some oiling problums, front of crank is blue like it got hot, rear is fine, will post pic's later this coming week, got to talk with the prior owner.
Ofer post up some pictures of this if you can, sure would like to see what you are dealing with on the problems this engine had. I am pretty sure I know some of the background of this engine and am curious. Thanks
ronchev is offline   Reply With Quote
Old 10-02-2019, 05:11 PM   #11
2SSRS@Gen5diy
 
2SSRS@Gen5diy's Avatar
 
Drives: To many to list
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 15,575
Quote:
Originally Posted by ronchev View Post
Ofer post up some pictures of this if you can, sure would like to see what you are dealing with on the problems this engine had. I am pretty sure I know some of the background of this engine and am curious. Thanks
So i was wrong on the motor over heating it a coating GM put's the crank, its a different color on machined surfaces, and looked like the crank got hot, it did not.


I have some pics to share, i will let them do all the talking.
Attached Images
      
2SSRS@Gen5diy is offline   Reply With Quote
Old 10-02-2019, 05:17 PM   #12
2SSRS@Gen5diy
 
2SSRS@Gen5diy's Avatar
 
Drives: To many to list
Join Date: Oct 2008
Location: By the lake in AZ
Posts: 15,575
I will leave this pic here so you can see the damage to the lifter bore.
Attached Images
 
2SSRS@Gen5diy is offline   Reply With Quote
Old 10-02-2019, 05:42 PM   #13
MrRaZ28
@MrRaZ28
 
MrRaZ28's Avatar
 
Drives: 2014 Z28 #80
Join Date: Oct 2009
Location: Garland Tx
Posts: 533
Wow... that's... um.. not good. Ouch!
__________________
Formerly Chevy2tehB0ne
IG: @razinha_motorsports
.
MrRaZ28 is offline   Reply With Quote
Old 10-03-2019, 08:44 AM   #14
ronchev
 
ronchev's Avatar
 
Drives: 14' Red Z/28 #336
Join Date: Mar 2016
Location: Northen Indiana
Posts: 208
Thanks for posting these pics, was wondering how bad the lifter bore looked.
Is this a comp cams lifter?
Good luck on getting this back in shape, looks doable from the picture you posted.
ronchev is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:30 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.