Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Bigwormgraphix
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LFX Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 11-16-2019, 09:38 PM   #1
plaincamarojoe
 
Drives: 2014 Camaro 1LT
Join Date: Aug 2017
Location: Burlington,North Carolina
Posts: 15
Is it my PCM/ECM? PLEASE HELP!

I have a 2014 1LT V6...I decided to replace the original battery before it gets too cold out, so I replaced it with a 'Platinum' AGM battery from Advance auto.
It has been running 15 to 15.3 volts almost always [all week] as well as periodically flashing the check engine light. I bought a cheap OBD 2 reader
and I get the following codes ; P1682 Driver 5 / Line 2 and code P2535
Ignition 1 switch circuit high voltage {PCM]
From research one says to replace ignition switch / other says to replace the
PCM/ECM . I'm not sure what I did wrong replacing battery, and I dont want to keep replacing parts. Car was fine until the battery swap. Tried to reset/flash
with battery disconnect and fuse pull..still overcharging.
PLEASE HELP / MY ONLY CAR. THANK YOU!
plaincamarojoe is online now Report Post
plaincamarojoe is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:07 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.