Due to a technical issue, all posts made over the past 24-48 hours have been lost. We sincerely apologize for this!!!
 
Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Gen5DIY
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 10-18-2018, 09:35 AM   #1
mmaattppllaayy
 
Drives: '10 Camaro 2SS
Join Date: Jul 2013
Location: Charlotte, NC
Posts: 408
ZL1 Pump DW400 Swap

Has anyone swapped out the pump in a ZL1 module with the DW400 pump? Seems like a really great in between pump that could handle in the 800-900 range for fairly cheap.
mmaattppllaayy is offline   Reply With Quote
Old 10-18-2018, 10:49 PM   #2
Blakester
 
Drives: 2010 1ss
Join Date: Mar 2016
Location: Colorado Springs co
Posts: 128
Are you talking about just doing a pump swap to a higher flow non gm pump but in the oem fuel bucket?
Blakester is offline   Reply With Quote
Old 10-19-2018, 09:10 AM   #3
mmaattppllaayy
 
Drives: '10 Camaro 2SS
Join Date: Jul 2013
Location: Charlotte, NC
Posts: 408
Quote:
Originally Posted by Blakester View Post
Are you talking about just doing a pump swap to a higher flow non gm pump but in the oem fuel bucket?
Yes exactly.
mmaattppllaayy is offline   Reply With Quote
Old 10-19-2018, 05:18 PM   #4
Unavowed
 
Unavowed's Avatar
 
Drives: Twin turbo G8 GXP
Join Date: Dec 2012
Location: MD
Posts: 441
Over the winter I plan to swap my V2 pumps for the AEM upgrades. Hopefully some larger injectors also.
__________________
Unavowed is offline   Reply With Quote
Old 10-19-2018, 06:19 PM   #5
mmaattppllaayy
 
Drives: '10 Camaro 2SS
Join Date: Jul 2013
Location: Charlotte, NC
Posts: 408
Quote:
Originally Posted by Unavowed View Post
Over the winter I plan to swap my V2 pumps for the AEM upgrades. Hopefully some larger injectors also.
I am really more concerned with swapping out the single pump in a zl1 bucket for the larger dw400 if anyone has done that or similar larger pump.
mmaattppllaayy is offline   Reply With Quote
Old 10-19-2018, 11:18 PM   #6
Blakester
 
Drives: 2010 1ss
Join Date: Mar 2016
Location: Colorado Springs co
Posts: 128
Ive been wondering how this would work too. Had my eye on the walbro hellcat 525 pump. Price looks super reasonable. But I figured with a stock fpcm or even an adm tuned zl1 fpcm wouldn't allow you to take full advantage of a aftermarket pump.

I am sure the company's that sell fuel systems for our cars could do something to make this work. But I am also sure that they make way more money off the super expensive 2 or 3 pump systems.
Blakester is offline   Reply With Quote
Old 10-21-2018, 08:54 PM   #7
eLeSthree
 
Drives: 2011 Camaro SS 6sp
Join Date: Nov 2016
Location: Drivers Seat
Posts: 431
Pretty sure someone tried this. Try a search?
__________________
2011 Camaro SS M6
HP Tuners Pro
ESS Tuning Supercharger @ 10# 711/638
eLeSthree is offline   Reply With Quote
Old 10-21-2018, 09:38 PM   #8
mmaattppllaayy
 
Drives: '10 Camaro 2SS
Join Date: Jul 2013
Location: Charlotte, NC
Posts: 408
Quote:
Originally Posted by eLeSthree View Post
Pretty sure someone tried this. Try a search?
If you can find it post the link. I have searched quite a bit.
mmaattppllaayy is offline   Reply With Quote
Old 10-22-2018, 04:41 AM   #9
racesloth
Dan
 
Drives: 2010 Camaro 2SS IOM
Join Date: Nov 2013
Location: Northants UK
Posts: 550
I posted a thread about this before. It seems that there was the issue of having a PWM pump compatible with the FPCM and the FPCM being able to feed enough amps to the new pump or the wiring being up to it. The post was quite a while ago and the newer pumps have come a long way.

I recently dropped a ZL1 pump in my 2010 and was batting around the idea of using the old pump assy as donor to try swapping to a new larger pump.

The DW400 draws 16.5amps at 13.5volts - pretty sure that is higher than stock requirement.

https://www.deatschwerks.com/sites/w...ch%20Sheet.pdf
__________________
Dan

2010 IOM SS
Cam - Some bolt-ons
http://www.camaro5.com/forums/showth...&highlight=ysi

Last edited by racesloth; 10-22-2018 at 11:03 AM.
racesloth is offline   Reply With Quote
Old 10-22-2018, 02:08 PM   #10
0331Marine

 
0331Marine's Avatar
 
Drives: 2012 SS/RS MN6
Join Date: Mar 2016
Location: Covington Ga
Posts: 764
I'm running a CTSV pump with DW300 pumps with no issues.
0331Marine is offline   Reply With Quote
Old 10-22-2018, 02:57 PM   #11
eLeSthree
 
Drives: 2011 Camaro SS 6sp
Join Date: Nov 2016
Location: Drivers Seat
Posts: 431
Quote:
Originally Posted by 0331Marine View Post
I'm running a CTSV pump with DW300 pumps with no issues.
Do you run E85? About how much power has it been supporting?

I need a fuel system...
__________________
2011 Camaro SS M6
HP Tuners Pro
ESS Tuning Supercharger @ 10# 711/638
eLeSthree is offline   Reply With Quote
Old 10-22-2018, 03:01 PM   #12
Punisher_ATX
 
Drives: 2010 SS
Join Date: Jun 2015
Location: Austin
Posts: 424
Quote:
Originally Posted by eLeSthree View Post
Do you run E85? About how much power has it been supporting?

I need a fuel system...
Just finished installing the Vaporworx System in my car. Was pretty simple and in an application with a single 450 and no boost reference it would be even easier i feel.
Punisher_ATX is offline   Reply With Quote
Old 10-22-2018, 03:36 PM   #13
mrimpala02
 
Drives: Black 2SS RS w/White Stripes
Join Date: Mar 2011
Location: Katy, TX
Posts: 643
I have a CTS-V pump that I pulled a couple of months ago. I would like it to find a good home if anyone is interested.
__________________
2010 2SS/RS "ChriSStine":
Pat G Custom Turbo CamMotion Camshaft | AGP TT BB Garrett 62/65's | AGP/Fore Triple Pumps | ID1700X Injectors | Alky Control Twin Nozzle Meth | Custom 3" Exhaust | 3.27 gear set w/ Tru Trac | McLeod Twin RXT | Barton Short Throw Shifter | 6th Gen ZL1 Wheels | BMR 1.4" drop springs | Pfadt rear trailing arms & tie rods |

Installed by Me & Tuned by Pat G
mrimpala02 is offline   Reply With Quote
Old 10-22-2018, 08:06 PM   #14
fleebag
 
fleebag's Avatar
 
Drives: Moneypit
Join Date: Nov 2013
Location: Tx
Posts: 98
Quote:
Originally Posted by 0331Marine View Post
I'm running a CTSV pump with DW300 pumps with no issues.
I did same couple years ago, not e85 yet but twins with 127lb injectors, 55%dc.
Not sure if I'm gonna go bigger for e85
fleebag is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:51 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.