Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Roto-Fab
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing


Reply
 
Thread Tools
Old 05-22-2021, 01:27 PM   #1
Greencamaro1234
 
Drives: 2011 Camaro LS
Join Date: Jul 2018
Location: South Carolina
Posts: 150
Spark plugs

Hi everyone,just wondering if anyone has experienced this,recently replace my plugs at 130 k. Iíve had this car 10 Years but replaced them with delco set the gap 0.40 I donít drive this car everyday,once a week and most of that is in town,but probably have 1000 miles on it since I changed in February,so the other day was heading out of town,and was driving about 80 mph and it started cutting out,check engine light came on. Pulled all the plugs and all of them were doubled what they were suppose to be 0.80. Regapped them and drove it twice maybe 20 miles,and my check engine light comes back on,although not running bad yet,but guessing the gap is getting off.any advice.
Greencamaro1234 is offline   Reply With Quote
Old 05-22-2021, 08:39 PM   #2
Bigdumogre

 
Bigdumogre's Avatar
 
Drives: 2012 Camaro SS
Join Date: Dec 2019
Location: New York
Posts: 1,077
Where did you get the plugs from? Amazon sells Chinese fake ac delco products that aren’t that good. Maybe you have something like that?

I have iridium delco in mine and they are like new still after a year and half.
__________________
2012 Camaro 2SS/RS - K&N cai, Katech ported TB, GPI Ported/rod modded manifold, Texas speed 1 7/8 headers, HFC, Flowmaster 2 chambers with x pipe, Mishimoto CC, MSD wires, Roto fab washer relocation, DynoSteve tune, tru cool 40k trans cooler, apex scoop, heritage grill, jre dipstick mod

Complete street performance appointment booked - Cam, tsp CNC heads and converter.
Bigdumogre is offline   Reply With Quote
Old 05-23-2021, 08:33 AM   #3
Chris49066SS

 
Chris49066SS's Avatar
 
Drives: 2010 SS L99
Join Date: Sep 2018
Location: TN
Posts: 1,521
Quote:
Originally Posted by Bigdumogre View Post
Where did you get the plugs from? Amazon sells Chinese fake ac delco products that arenít that good. Maybe you have something like that?

I have iridium delco in mine and they are like new still after a year and half.
Agree, don't get plugs from Amazon. Mine were marketed as NGK TR6, but they made the car run terrible. Properly gapped and car was tuned on NGK TR6s (actual ones). Gotta get them at a place like Phastek, then you're getting legit products.
__________________
11.079 @ 122.99mph
The 11.079 pass: https://youtu.be/pz27Zq54t_E
Build thread - www.camaro5.com/forums/showthread.php?t=555371
Chris49066SS is offline   Reply With Quote
Old 05-23-2021, 10:07 AM   #4
Greencamaro1234
 
Drives: 2011 Camaro LS
Join Date: Jul 2018
Location: South Carolina
Posts: 150
I think I did get them from amazon but they were AC delco,with the correct part number,so probably go to auto zone and get some new ones.
Greencamaro1234 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.