Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Bigwormgraphix
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 03-27-2021, 05:53 PM   #1
Camaro227
 
Camaro227's Avatar
 
Drives: Toyota Puris
Join Date: Oct 2020
Location: Alaska
Posts: 35
Jerk when accelerating?

.

Last edited by Camaro227; 05-04-2021 at 06:44 PM.
Camaro227 is offline   Reply With Quote
Old 03-28-2021, 09:51 AM   #2
1JEWLDSSRS


 
1JEWLDSSRS's Avatar
 
Drives: 2011 SS-RS
Join Date: May 2011
Location: FLORIDA
Posts: 4,441
What year is your Camaro?? I had this happening back after I bought it and it turned out to be the filter housing cracked and was causing a high pressure fluid spike in the trans and was fixed under warranty as there was a TSB out on the issue. Mine is a 2011..
__________________
TSP STAGE 3 CAM,231/246 @112 LSA 614/641 LIFT, CIRCLE D 5C-4200-4500 CONVERTER,LOD INTAKE.CORSA EXHAUST. DSS 1 PC DS. PEGASUS SOLID CRADLE MOUNTS. 486RWTQ/475RWHP.LOTS MORE.
1JEWLDSSRS is offline   Reply With Quote
Old 03-28-2021, 10:45 AM   #3
Camaro227
 
Camaro227's Avatar
 
Drives: Toyota Puris
Join Date: Oct 2020
Location: Alaska
Posts: 35
Thank you.

Last edited by Camaro227; 03-28-2021 at 10:51 AM. Reason: Duplicate
Camaro227 is offline   Reply With Quote
Old 03-28-2021, 10:50 AM   #4
Camaro227
 
Camaro227's Avatar
 
Drives: Toyota Puris
Join Date: Oct 2020
Location: Alaska
Posts: 35
Quote:
Originally Posted by 1JEWLDSSRS View Post
What year is your Camaro?? I had this happening back after I bought it and it turned out to be the filter housing cracked and was causing a high pressure fluid spike in the trans and was fixed under warranty as there was a TSB out on the issue. Mine is a 2011..
It's a 2012 SS. Do you happen. To have the TSB#?

Thanks
Camaro227 is offline   Reply With Quote
Old 03-28-2021, 01:34 PM   #5
1JEWLDSSRS


 
1JEWLDSSRS's Avatar
 
Drives: 2011 SS-RS
Join Date: May 2011
Location: FLORIDA
Posts: 4,441
Here you go sir, I found it. Mine was doing exactly what yours was doing and this is what they found when they took my pan off and checked the filter, it was split just like the first pic and there was a hole in it as well and they found tiny plastic pieces in my valve body and fluid, so they replaced EVERYTHING including the converter. Good luck..

https://static.nhtsa.gov/odi/tsbs/20...39489-5982.pdf
__________________
TSP STAGE 3 CAM,231/246 @112 LSA 614/641 LIFT, CIRCLE D 5C-4200-4500 CONVERTER,LOD INTAKE.CORSA EXHAUST. DSS 1 PC DS. PEGASUS SOLID CRADLE MOUNTS. 486RWTQ/475RWHP.LOTS MORE.
1JEWLDSSRS is offline   Reply With Quote
Old 03-28-2021, 02:40 PM   #6
Camaro227
 
Camaro227's Avatar
 
Drives: Toyota Puris
Join Date: Oct 2020
Location: Alaska
Posts: 35
Quote:
Originally Posted by 1JEWLDSSRS View Post
Here you go sir, I found it. Mine was doing exactly what yours was doing and this is what they found when they took my pan off and checked the filter, it was split just like the first pic and there was a hole in it as well and they found tiny plastic pieces in my valve body and fluid, so they replaced EVERYTHING including the converter. Good luck..

https://static.nhtsa.gov/odi/tsbs/20...39489-5982.pdf
Wow that's strange. Thanks for the information. I won't be able to replace the all the parts due to no warranty .But I'll try to get it in sometime to drain the fluid and swap the filter.
Camaro227 is offline   Reply With Quote
Old 03-28-2021, 04:23 PM   #7
1JEWLDSSRS


 
1JEWLDSSRS's Avatar
 
Drives: 2011 SS-RS
Join Date: May 2011
Location: FLORIDA
Posts: 4,441
Quote:
Originally Posted by Camaro227 View Post
Wow that's strange. Thanks for the information. I won't be able to replace the all the parts due to no warranty .But I'll try to get it in sometime to drain the fluid and swap the filter.
They only replaced all the parts because I had such a nice size hole in the filter and plastic was everywhere inside, so to be safe, and it was covered, GM just said to replace it all. Might only be that yours is only cracked, and if so and that was the issue, you will be good, if it fixes the issue you are having. The reason I think it had that pressure spike I was told was the pump was shimmed incorrectly, so that got fixed as well. Good luck and hope this was of help to you. Cheers..
__________________
TSP STAGE 3 CAM,231/246 @112 LSA 614/641 LIFT, CIRCLE D 5C-4200-4500 CONVERTER,LOD INTAKE.CORSA EXHAUST. DSS 1 PC DS. PEGASUS SOLID CRADLE MOUNTS. 486RWTQ/475RWHP.LOTS MORE.
1JEWLDSSRS is offline   Reply With Quote
Old 04-08-2021, 02:34 PM   #8
Camaro227
 
Camaro227's Avatar
 
Drives: Toyota Puris
Join Date: Oct 2020
Location: Alaska
Posts: 35
Question

Quote:
Originally Posted by 1JEWLDSSRS View Post
They only replaced all the parts because I had such a nice size hole in the filter and plastic was everywhere inside, so to be safe, and it was covered, GM just said to replace it all. Might only be that yours is only cracked, and if so and that was the issue, you will be good, if it fixes the issue you are having. The reason I think it had that pressure spike I was told was the pump was shimmed incorrectly, so that got fixed as well. Good luck and hope this was of help to you. Cheers..

Okay, just got the fluid and filter changed. He gave me the old filter and everything looks good and the old fluid was cherry red. I will try testing it tomorrow and see what happens.
Camaro227 is offline   Reply With Quote
Old 04-08-2021, 07:30 PM   #9
1JEWLDSSRS


 
1JEWLDSSRS's Avatar
 
Drives: 2011 SS-RS
Join Date: May 2011
Location: FLORIDA
Posts: 4,441
Quote:
Originally Posted by Camaro227 View Post
Okay, just got the fluid and filter changed. He gave me the old filter and everything looks good and the old fluid was cherry red. I will try testing it tomorrow and see what happens.
Cool, good luck.
__________________
TSP STAGE 3 CAM,231/246 @112 LSA 614/641 LIFT, CIRCLE D 5C-4200-4500 CONVERTER,LOD INTAKE.CORSA EXHAUST. DSS 1 PC DS. PEGASUS SOLID CRADLE MOUNTS. 486RWTQ/475RWHP.LOTS MORE.
1JEWLDSSRS is offline   Reply With Quote
Old 04-14-2021, 06:55 PM   #10
Camaro227
 
Camaro227's Avatar
 
Drives: Toyota Puris
Join Date: Oct 2020
Location: Alaska
Posts: 35
Quote:
Originally Posted by 1JEWLDSSRS View Post
Cool, good luck.

Alright think I finally got it! I got the fluid changed and it was shifting like garbage under wot. Come to find out the fluid was low... He topped of the fluid and it seems to be shifting great with no issues. So I'm thinking maybe the fluid from the factory wasn't quite enough.... That's what was causing the jerk.
Camaro227 is offline   Reply With Quote
Old 04-15-2021, 08:17 AM   #11
gtstorey

 
Drives: 2010 Camaro SS2,L99, LSA SC
Join Date: Aug 2017
Location: Huntsville, AL
Posts: 776
Quote:
Originally Posted by Camaro227 View Post
Alright think I finally got it! I got the fluid changed and it was shifting like garbage under wot. Come to find out the fluid was low... He topped of the fluid and it seems to be shifting great with no issues. So I'm thinking maybe the fluid from the factory wasn't quite enough.... That's what was causing the jerk.
Circle D Transmission suggests 3/4 quart over fill.
https://www.circledtrans.com/files/R...-June-2013.pdf
gtstorey is offline   Reply With Quote
Old 04-15-2021, 08:23 AM   #12
1JEWLDSSRS


 
1JEWLDSSRS's Avatar
 
Drives: 2011 SS-RS
Join Date: May 2011
Location: FLORIDA
Posts: 4,441
Quote:
Originally Posted by gtstorey View Post
Circle D Transmission suggests 3/4 quart over fill.
https://www.circledtrans.com/files/R...-June-2013.pdf
Yep, ^^^ this exactly. When they do a fluid change and fill it up to "their" specs, you will notice it a tad low, so adding a little more will make it shift better.
__________________
TSP STAGE 3 CAM,231/246 @112 LSA 614/641 LIFT, CIRCLE D 5C-4200-4500 CONVERTER,LOD INTAKE.CORSA EXHAUST. DSS 1 PC DS. PEGASUS SOLID CRADLE MOUNTS. 486RWTQ/475RWHP.LOTS MORE.
1JEWLDSSRS is offline   Reply With Quote
Old 04-15-2021, 08:24 AM   #13
1JEWLDSSRS


 
1JEWLDSSRS's Avatar
 
Drives: 2011 SS-RS
Join Date: May 2011
Location: FLORIDA
Posts: 4,441
Quote:
Originally Posted by Camaro227 View Post
Alright think I finally got it! I got the fluid changed and it was shifting like garbage under wot. Come to find out the fluid was low... He topped of the fluid and it seems to be shifting great with no issues. So I'm thinking maybe the fluid from the factory wasn't quite enough.... That's what was causing the jerk.
Very cool!!! Enjoy that baby!!
__________________
TSP STAGE 3 CAM,231/246 @112 LSA 614/641 LIFT, CIRCLE D 5C-4200-4500 CONVERTER,LOD INTAKE.CORSA EXHAUST. DSS 1 PC DS. PEGASUS SOLID CRADLE MOUNTS. 486RWTQ/475RWHP.LOTS MORE.
1JEWLDSSRS is offline   Reply With Quote
Old 04-15-2021, 01:04 PM   #14
ElderJ
 
ElderJ's Avatar
 
Drives: 2014 Camaro 1LT
Join Date: Aug 2019
Location: Southern Indiana
Posts: 164
"Jerk when accelerating?"


Uhh...no, but to each his own. I'm too old and too married for all that...
ElderJ is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:47 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.