Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Solo Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 01-24-2013, 09:01 PM   #1
Sgtslaughterrrr
 
Drives: 2010 camaro 2ss pt67mm single turbo
Join Date: Jan 2013
Location: Wichita kansas
Posts: 41
Need help on high idle turbo car

Anybody have any ideas whats causing my high idle, heres a little info on car i purchased car with 67mm single turbo looks to be custom made, turbo has a intercooler but no blow off valve, im getting oil in turbo piping and can see oil on my maf, my check engine light is on, today i pulled the maf of and cleaned it with carb cleaner and engine code went off but car will still idle around 1100 rpm for awhile before returing to 750 normal idle, engine will surge to 2000 rpm when coming out of gear at redlights sometimes and then back down to 1100 rpm, when engine is cold it will start up like normal high idle till warm and to a normal idle of 750rpm. Code is po507, po113 and po102 but clears when maf is clean of oil, but idle still high when driving in town, wideband meter reads 11.5 on wot and 12 to 13 when high way speeds and sometimes highway speeds will read 14 to 15 on wideband something is wrong, gas mileage sucks, im going to rebuild turbo and install blow off valve next week, maybe that wiill fix my oil in turbo line problem, is there another sensor that could be oiled up thats causeing high idle? Running 8psi on turbo , willbe tring to clean up someone elses build, car has 14000 miles ss m6 car thanks
Sgtslaughterrrr is offline   Reply With Quote
Old 01-25-2013, 01:43 PM   #2
EliteCZM523
 
EliteCZM523's Avatar
 
Drives: 2010 2SS/RS
Join Date: Sep 2010
Location: Westchester, NY
Posts: 93
Its most likely in the tune - do u have access to EFI Live or HPTuners?
__________________
ARH 1 7/8 w/ cats, Borla ATAK Axle Back, VaraRam, ECS Cam, JDP Halo Kit, Technostalgia Tail Lights, AAC Ghosted SMD Side Markers, Reverse Lights, P13W Plasma DRL's, DRL Harness, Kenwood 9990HD, Scosche Kit, and tons more
EliteCZM523 is offline   Reply With Quote
Old 01-25-2013, 02:41 PM   #3
Chris-HPS
 
Chris-HPS's Avatar
 
Drives: 2008Corvette
Join Date: Feb 2012
Location: Ga
Posts: 691
Quote:
Originally Posted by Sgtslaughterrrr View Post
Anybody have any ideas whats causing my high idle, heres a little info on car i purchased car with 67mm single turbo looks to be custom made, turbo has a intercooler but no blow off valve, im getting oil in turbo piping and can see oil on my maf, my check engine light is on, today i pulled the maf of and cleaned it with carb cleaner and engine code went off but car will still idle around 1100 rpm for awhile before returing to 750 normal idle, engine will surge to 2000 rpm when coming out of gear at redlights sometimes and then back down to 1100 rpm, when engine is cold it will start up like normal high idle till warm and to a normal idle of 750rpm. Code is po507, po113 and po102 but clears when maf is clean of oil, but idle still high when driving in town, wideband meter reads 11.5 on wot and 12 to 13 when high way speeds and sometimes highway speeds will read 14 to 15 on wideband something is wrong, gas mileage sucks, im going to rebuild turbo and install blow off valve next week, maybe that wiill fix my oil in turbo line problem, is there another sensor that could be oiled up thats causeing high idle? Running 8psi on turbo , willbe tring to clean up someone elses build, car has 14000 miles ss m6 car thanks

First off you need a Blow off valve. Allowing the excess pressure to bleed off thru the turbo is a big no,no and will cause damage to the turbo as you mentioned. The high idle is probably a tuning issue. When cruising the AFR should be in the 14.7 range as well. WOT AFR seems to fine as long as there is no KR. Any pics of the turbo kit?

Chris
Chris-HPS is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:14 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.