Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > General Camaro Forums > 5th Gen Camaro SS LS LT General Discussions


Reply
 
Thread Tools
Old 10-22-2018, 11:51 AM   #1
3rdGenAg2010
 
Drives: 2014 Camaro 1LE
Join Date: Jul 2017
Location: Houston
Posts: 71
Question Hero Tail lights slow to light up

I just installed the Hero tail lights, and when I press the brake the third brake light comes on immediately as it should, but the Hero tail lights have a 1/2 second delay.... Any idea what could cause this?

TIA
3rdGenAg2010 is offline   Reply With Quote
Old 10-22-2018, 12:39 PM   #2
JerTM

 
JerTM's Avatar
 
Drives: 2011 2SS/RS M6
Join Date: Oct 2015
Location: Utah
Posts: 1,843
Are the Hero lights LED or incandescent? LED light up a lot quicker than incandescent.
JerTM is offline   Reply With Quote
Old 10-22-2018, 12:53 PM   #3
SSEssence
Instagram: Sangstah
 
SSEssence's Avatar
 
Drives: 2014 Camaro 1SS RS SIM
Join Date: Sep 2016
Location: Buena Park, CA.
Posts: 1,842
^I believe they are LED
__________________
2014 SS - L99 1SS/RS - "AleSSandra"
SSEssence is offline   Reply With Quote
Old 10-22-2018, 12:58 PM   #4
3rdGenAg2010
 
Drives: 2014 Camaro 1LE
Join Date: Jul 2017
Location: Houston
Posts: 71
Theyre LED. But so were the stock RS taillights
3rdGenAg2010 is offline   Reply With Quote
Old 10-22-2018, 01:50 PM   #5
hazy

 
Drives: 2011 2SS/RS
Join Date: Feb 2014
Location: H-Town
Posts: 991
Quote:
Originally Posted by 3rdGenAg2010 View Post
Theyre LED. But so were the stock RS taillights
Stock RS lights are not LED. They have a 3157 incandescent bulb

There are a few aftermarket LED setups, though, so if you purchased the vehicle used it may have had one of those installed.
hazy is offline   Reply With Quote
Old 10-22-2018, 02:02 PM   #6
SSEssence
Instagram: Sangstah
 
SSEssence's Avatar
 
Drives: 2014 Camaro 1SS RS SIM
Join Date: Sep 2016
Location: Buena Park, CA.
Posts: 1,842
the 14-15 RS tail lights are LED.
__________________
2014 SS - L99 1SS/RS - "AleSSandra"
SSEssence is offline   Reply With Quote
Old 10-22-2018, 02:32 PM   #7
hazy

 
Drives: 2011 2SS/RS
Join Date: Feb 2014
Location: H-Town
Posts: 991
ahh understood - didn't even think about the updated version. My bad.
hazy is offline   Reply With Quote
Old 10-22-2018, 02:35 PM   #8
3rdGenAg2010
 
Drives: 2014 Camaro 1LE
Join Date: Jul 2017
Location: Houston
Posts: 71
Quote:
Originally Posted by SSEssence View Post
the 14-15 RS tail lights are LED.
Correct.
3rdGenAg2010 is offline   Reply With Quote
Old 10-22-2018, 03:29 PM   #9
3rdGenAg2010
 
Drives: 2014 Camaro 1LE
Join Date: Jul 2017
Location: Houston
Posts: 71
So im told that the half a second delay is normal. Can any of the guys that purchased the Hero taillights confirm?
3rdGenAg2010 is offline   Reply With Quote
Old 10-22-2018, 03:40 PM   #10
J Rod
 
J Rod's Avatar
 
Drives: '14 BRM 1LE 2SS/RS
Join Date: Nov 2017
Location: Ft. Wayne, IN
Posts: 411
I'll check mine out tonight and get back with you
__________________
LSA swap in progress.... RotoFab CAI, Bo White TB, Coated SP 1-7/8" LTs, IKON Z28 Grill & Spoiler, Hero Tails - 424rwhp/410rwtq
J Rod is offline   Reply With Quote
Old 10-22-2018, 05:06 PM   #11
3rdGenAg2010
 
Drives: 2014 Camaro 1LE
Join Date: Jul 2017
Location: Houston
Posts: 71
Quote:
Originally Posted by J Rod View Post
I'll check mine out tonight and get back with you
Awesome thanks!
3rdGenAg2010 is offline   Reply With Quote
Old 10-22-2018, 06:23 PM   #12
huggett
 
Drives: 2015 Camaro 2SS LS3
Join Date: May 2013
Location: Wisconsin
Posts: 73
I also have almost a 1 second delay in the Hero brake lights lighting up.
Installed on 2015 SS non-rs. I love the look, but not happy about the delay.
huggett is offline   Reply With Quote
Old 10-22-2018, 06:25 PM   #13
3rdGenAg2010
 
Drives: 2014 Camaro 1LE
Join Date: Jul 2017
Location: Houston
Posts: 71
Quote:
Originally Posted by huggett View Post
I also have almost a 1 second delay in the Hero brake lights lighting up.
Installed on 2015 SS non-rs. I love the look, but not happy about the delay.
Dang thats unfortunate to hear....
3rdGenAg2010 is offline   Reply With Quote
Old 10-22-2018, 06:32 PM   #14
huggett
 
Drives: 2015 Camaro 2SS LS3
Join Date: May 2013
Location: Wisconsin
Posts: 73
Quote:
Originally Posted by 3rdGenAg2010 View Post
Dang thats unfortunate to hear....
I guess I might be able to live with it, but definitely not ideal
huggett is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:39 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.