Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Emblempros
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Forced Induction - V8


Reply
 
Thread Tools
Old 05-27-2020, 07:22 PM   #85
C@mero
 
Drives: Camaro 1LE
Join Date: Jan 2020
Location: Chicago
Posts: 15
Quote:
Originally Posted by RupertPupkin View Post
Might be picking up the car tomorrow.... Hold for updates.
Good to hear OP.
C@mero is offline   Reply With Quote
Old 05-28-2020, 02:58 PM   #86
RupertPupkin
 
Drives: 2014 Camaro SS 1Le
Join Date: Feb 2016
Location: IL
Posts: 602
Car made 730rwhp. Doing some more revisions to see if we can squeeze more out of it. Seems kind of low, but it is just numbers.

Thoughts?
__________________
14SS 1LE 2SS/RS/Recaros|Tick Polluter Stg-3|E85
LS7 Lifters|BTR Springs|Speed Engineering LTs|Muffler Mod|ECS 1500|DSX Aux Pump|DSX Flex Fuel Sensor|FIC 127#|ATI Balancer|DashLogic| McLeod RXT|BMR 1.4 Springs|MightyMouse Wild|AEM WideBand|AEM BoostGauge|ZL1Addons Splitter|VA Sideskirts|POWER : 737whp/635trq

Last edited by RupertPupkin; 05-28-2020 at 03:16 PM.
RupertPupkin is offline   Reply With Quote
Old 05-28-2020, 03:41 PM   #87
RupertPupkin
 
Drives: 2014 Camaro SS 1Le
Join Date: Feb 2016
Location: IL
Posts: 602
737/635

Dyno graph.
Attachment 1033515
__________________
14SS 1LE 2SS/RS/Recaros|Tick Polluter Stg-3|E85
LS7 Lifters|BTR Springs|Speed Engineering LTs|Muffler Mod|ECS 1500|DSX Aux Pump|DSX Flex Fuel Sensor|FIC 127#|ATI Balancer|DashLogic| McLeod RXT|BMR 1.4 Springs|MightyMouse Wild|AEM WideBand|AEM BoostGauge|ZL1Addons Splitter|VA Sideskirts|POWER : 737whp/635trq

Last edited by RupertPupkin; 05-28-2020 at 03:59 PM.
RupertPupkin is offline   Reply With Quote
Old 05-28-2020, 03:45 PM   #88
racesloth
Dan
 
Drives: 2010 Camaro 2SS IOM
Join Date: Nov 2013
Location: Georgia, USA not the other one
Posts: 862
737 - Not too shabby...
__________________
Dan

2010 IOM SS
YSI-B, Pat G Cam, Ported CTS-V Heads, ARH LTs MBRP 3" exhaust
http://www.camaro5.com/forums/showth...&highlight=ysi
racesloth is offline   Reply With Quote
Old 05-28-2020, 03:48 PM   #89
Valkyrie14
Valkyrie14
 
Valkyrie14's Avatar
 
Drives: Chevrolet Camaro SS
Join Date: Mar 2020
Location: Hayward, Wisconsin
Posts: 292
737! Way to go.
__________________
2014 SS LS3/LSA Supercharger, ID 80# injectors, LT Headers, BBK 95mm throttle body, Roto-Fab CAI, VaraRam, Elite E2 catch can 160 Thermostat, HP Tuners, JL Audio system.
Valkyrie14 is offline   Reply With Quote
Old 05-28-2020, 04:00 PM   #90
RupertPupkin
 
Drives: 2014 Camaro SS 1Le
Join Date: Feb 2016
Location: IL
Posts: 602
Quote:
Originally Posted by racesloth View Post
737 - Not too shabby...
Quote:
Originally Posted by Valkyrie14 View Post
737! Way to go.
Thanks. Was shooting 800....but... I’m happy. Picked up 300 to the wheel.

Seems like there’s belt slip or spark issues up top.
__________________
14SS 1LE 2SS/RS/Recaros|Tick Polluter Stg-3|E85
LS7 Lifters|BTR Springs|Speed Engineering LTs|Muffler Mod|ECS 1500|DSX Aux Pump|DSX Flex Fuel Sensor|FIC 127#|ATI Balancer|DashLogic| McLeod RXT|BMR 1.4 Springs|MightyMouse Wild|AEM WideBand|AEM BoostGauge|ZL1Addons Splitter|VA Sideskirts|POWER : 737whp/635trq
RupertPupkin is offline   Reply With Quote
Old 05-28-2020, 04:01 PM   #91
racesloth
Dan
 
Drives: 2010 Camaro 2SS IOM
Join Date: Nov 2013
Location: Georgia, USA not the other one
Posts: 862
Hey, you are making more than my YSi setup. I am having real belt slip issues...
__________________
Dan

2010 IOM SS
YSI-B, Pat G Cam, Ported CTS-V Heads, ARH LTs MBRP 3" exhaust
http://www.camaro5.com/forums/showth...&highlight=ysi
racesloth is offline   Reply With Quote
Old 05-28-2020, 04:09 PM   #92
RupertPupkin
 
Drives: 2014 Camaro SS 1Le
Join Date: Feb 2016
Location: IL
Posts: 602
What can I do to relieve the belt issue? Swap it to a 10 rib, cog? Cog might be too extreme
__________________
14SS 1LE 2SS/RS/Recaros|Tick Polluter Stg-3|E85
LS7 Lifters|BTR Springs|Speed Engineering LTs|Muffler Mod|ECS 1500|DSX Aux Pump|DSX Flex Fuel Sensor|FIC 127#|ATI Balancer|DashLogic| McLeod RXT|BMR 1.4 Springs|MightyMouse Wild|AEM WideBand|AEM BoostGauge|ZL1Addons Splitter|VA Sideskirts|POWER : 737whp/635trq
RupertPupkin is offline   Reply With Quote
Old 05-28-2020, 04:50 PM   #93
stevieturbo

 
Drives: Volvo
Join Date: Nov 2010
Location: Norn Iron
Posts: 1,010
Quote:
Originally Posted by RupertPupkin View Post
What can I do to relieve the belt issue? Swap it to a 10 rib, cog? Cog might be too extreme
Depends what's causing it in the first place.

Belt routing ? What tensioner and arrangement ? What belt ? What rib at present ?

Belts stretch huge amounts under load, so you need a very good belt, and whatever belt is used, you need it to pretty much a very tight fit right from the word go, ie, tensioner at full stop, to give it all the best chance of keeping it in tension as the belt stretches.
stevieturbo is offline   Reply With Quote
Old 05-28-2020, 08:08 PM   #94
eLeSthree

 
Drives: 2011 Camaro SS 6sp
Join Date: Nov 2016
Location: Drivers Seat
Posts: 1,205
Quote:
Originally Posted by RupertPupkin View Post
What can I do to relieve the belt issue? Swap it to a 10 rib, cog? Cog might be too extreme
What gives you the impression the belt is slipping? How much boost is it making?

If you have a way to log boost vs rpm it will tell you if you’re seeing slip.

They dyno chart looks wierd up top. Whats the fuel pressure doing during a run? Is this on e85? Do you know how much timing was used?
__________________
2011 Camaro SS M6
DSX Tuning
HP Tuners Pro
ESS Tuning G3X Blower 913whp/787tq@6400
JRE Tuned
eLeSthree is offline   Reply With Quote
Old 05-28-2020, 08:19 PM   #95
RupertPupkin
 
Drives: 2014 Camaro SS 1Le
Join Date: Feb 2016
Location: IL
Posts: 602
Quote:
Originally Posted by eLeSthree View Post
What gives you the impression the belt is slipping? How much boost is it making?

If you have a way to log boost vs rpm it will tell you if you’re seeing slip.

They dyno chart looks wierd up top. Whats the fuel pressure doing during a run? Is this on e85? Do you know how much timing was used?
Boost was only around 11-12lbs.

93 octane timing around 19*. And e85 is around 25*

It’s tuned in 93 and e85.

Bt skipping was more on an assumption, and was suggested on another thread.


What info should I ask Juiced for?
__________________
14SS 1LE 2SS/RS/Recaros|Tick Polluter Stg-3|E85
LS7 Lifters|BTR Springs|Speed Engineering LTs|Muffler Mod|ECS 1500|DSX Aux Pump|DSX Flex Fuel Sensor|FIC 127#|ATI Balancer|DashLogic| McLeod RXT|BMR 1.4 Springs|MightyMouse Wild|AEM WideBand|AEM BoostGauge|ZL1Addons Splitter|VA Sideskirts|POWER : 737whp/635trq
RupertPupkin is offline   Reply With Quote
Old 05-28-2020, 08:34 PM   #96
RobZL1
fo'shizZL1
 
RobZL1's Avatar
 
Drives: 2014 ZL1
Join Date: Aug 2017
Location: ATL
Posts: 669
See if they have a plot of boost they can add to the bottom of that chart. Something weird is definitely going on up top, especially since it's already shown with a curve-smoothing factor of 5...

My guess is either belt slip or clutch slip. Boost should rise smoothly and constantly in your case. To see if it's clutch slip, you can look at a plot of RPM/MPH vs RPM. It should be a straight, and slightly decreasing line.

If either plot is screwy, you'll know your culprit (or you can rule those out if they look good).
__________________
2014 Red Hot #1503 | TBD SAE | RotoFab | 28% OD | GP Tuning 2.5 Cam | 2" TSP LT's | JMS BAP | ID850 | TR7IX | MSD Wires | APEX Catch Can | Metco Breather | Monster LT1-S Triple | C&R HEX | RotoFab Res | Racing Brake Rotors | Self-Tuned w/ HPT
RobZL1 is offline   Reply With Quote
Old 05-28-2020, 09:13 PM   #97
eLeSthree

 
Drives: 2011 Camaro SS 6sp
Join Date: Nov 2016
Location: Drivers Seat
Posts: 1,205
Id ask where the boost is. Is that the new RXT im there already?
__________________
2011 Camaro SS M6
DSX Tuning
HP Tuners Pro
ESS Tuning G3X Blower 913whp/787tq@6400
JRE Tuned
eLeSthree is offline   Reply With Quote
Old 05-28-2020, 10:14 PM   #98
RupertPupkin
 
Drives: 2014 Camaro SS 1Le
Join Date: Feb 2016
Location: IL
Posts: 602
Quote:
Originally Posted by RobZL1 View Post
See if they have a plot of boost they can add to the bottom of that chart. Something weird is definitely going on up top, especially since it's already shown with a curve-smoothing factor of 5...

My guess is either belt slip or clutch slip. Boost should rise smoothly and constantly in your case. To see if it's clutch slip, you can look at a plot of RPM/MPH vs RPM. It should be a straight, and slightly decreasing line.

If either plot is screwy, you'll know your culprit (or you can rule those out if they look good).

Did tighten the tensioner, smoothed it out a little bit. Did some highway pulls, and nothing out of the ordinary popped up, or felt different.


Quote:
Originally Posted by eLeSthree View Post
Id ask where the boost is. Is that the new RXT im there already?
No, still on the stock clutch.
__________________
14SS 1LE 2SS/RS/Recaros|Tick Polluter Stg-3|E85
LS7 Lifters|BTR Springs|Speed Engineering LTs|Muffler Mod|ECS 1500|DSX Aux Pump|DSX Flex Fuel Sensor|FIC 127#|ATI Balancer|DashLogic| McLeod RXT|BMR 1.4 Springs|MightyMouse Wild|AEM WideBand|AEM BoostGauge|ZL1Addons Splitter|VA Sideskirts|POWER : 737whp/635trq
RupertPupkin is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.