Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Phastek Performance
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing


Reply
 
Thread Tools
Old 02-10-2022, 06:47 PM   #1
Cali_Camaro_SS

 
Cali_Camaro_SS's Avatar
 
Drives: 2010 Camaro 1SS (BLACK)
Join Date: Jan 2010
Location: Cali
Posts: 855
AC blowing warm.

Hey, so recently my ac has stopped blowing cold air and is just very warm. I went to autozone and got a r-134a bottle and when I just put the hose on the low side valve the gauge showed at 55psi and was directly on the line between green and red.
My car is a 2010 SS LS3 with 67k miles. AC belt is still on, checked just incase.
Any ideas what I can do or should do?

Thanks.
__________________
_________________
1SS: Dnyatech LT Headers | Dynamaxx CatBack | Diablo Tune | Intake | Pfatds Springs | Heritage Grill | Blacked out Bezels | Black Chevy Sign | Blacked out Wheels | Tint | HIDs w/Error code Eliminator | Green Dome/Trunk Light |

Cali_Camaro_SS is offline   Reply With Quote
Old 02-10-2022, 07:32 PM   #2
0stones0
It donít come easy.
 
0stones0's Avatar
 
Drives: 2010 2SS RS M6
Join Date: May 2014
Location: WI
Posts: 1,198
Possibly heater blend door. Do a search on the forum. You won’t be happy.
__________________
0stones0 is online now   Reply With Quote
Old 02-10-2022, 09:49 PM   #3
Cali_Camaro_SS

 
Cali_Camaro_SS's Avatar
 
Drives: 2010 Camaro 1SS (BLACK)
Join Date: Jan 2010
Location: Cali
Posts: 855
Ok so I looked it up and yea I don’t like it at all ��. How would I know if that’s the problem or if it’s something else? Just take it in for a diagnostic?
__________________
_________________
1SS: Dnyatech LT Headers | Dynamaxx CatBack | Diablo Tune | Intake | Pfatds Springs | Heritage Grill | Blacked out Bezels | Black Chevy Sign | Blacked out Wheels | Tint | HIDs w/Error code Eliminator | Green Dome/Trunk Light |

Cali_Camaro_SS is offline   Reply With Quote
Old 02-11-2022, 08:29 PM   #4
Tajefe Couple

 
Tajefe Couple's Avatar
 
Drives: Never just fly under the radar
Join Date: Jul 2015
Location: Kansas
Posts: 1,457
Think you can crimp the rubber hose going to the heater core or both hoses real quick with some vice grips and see if it starts blowing cold with no coolant going to the core. If so probably the blend door.
__________________
1-8-4-3-6-5-7-2
Old Skool
Tajefe Couple is offline   Reply With Quote
Old 02-12-2022, 09:57 AM   #5
camguynj


 
camguynj's Avatar
 
Drives: '13 SS/RS LS3 BRM Cammed NPP
Join Date: Jan 2013
Location: NJ
Posts: 3,475
I would think that if the blend door is broken the heat temp wouldn’t change no matter what the temp dial position was turned to as the blend door can’t move. Try it and post back your result. Another thing to try is if the windshield fogs up, turn on the defroster with the a/c on and temp set to med-high. If windshield clears it means the a/c is working.
If it doesn’t clear then the a/c isn’t working.
camguynj is offline   Reply With Quote
Old 02-26-2022, 06:34 PM   #6
Natepetz
UNCTRLD
 
Natepetz's Avatar
 
Drives: 2012 RS/SS2 Convertible.
Join Date: Feb 2017
Location: Tulsa OK
Posts: 4
I'm guessing the blend door. I replaced mine. Think it was $26 on Rockauto.com. There are videos on youtube to cut out the old and install the new one. Takes some time, but way cheaper than having the dealer do it for $2,500-3,000.
Natepetz is offline   Reply With Quote
Old 02-27-2022, 09:49 PM   #7
Cali_Camaro_SS

 
Cali_Camaro_SS's Avatar
 
Drives: 2010 Camaro 1SS (BLACK)
Join Date: Jan 2010
Location: Cali
Posts: 855
Hey thanks for all the info. Iíll try some of these ideas out and get back to this post in a bit 👍
__________________
_________________
1SS: Dnyatech LT Headers | Dynamaxx CatBack | Diablo Tune | Intake | Pfatds Springs | Heritage Grill | Blacked out Bezels | Black Chevy Sign | Blacked out Wheels | Tint | HIDs w/Error code Eliminator | Green Dome/Trunk Light |

Cali_Camaro_SS is offline   Reply With Quote
Old 02-28-2022, 01:49 AM   #8
0stones0
It donít come easy.
 
0stones0's Avatar
 
Drives: 2010 2SS RS M6
Join Date: May 2014
Location: WI
Posts: 1,198
Quote:
Originally Posted by Cali_Camaro_SS View Post
Hey thanks for all the info. Iíll try some of these ideas out and get back to this post in a bit 👍
This might help you, as well.

Heater Blend Door Forum Database
__________________
0stones0 is online now   Reply With Quote
Old 05-27-2022, 01:19 PM   #9
Cali_Camaro_SS

 
Cali_Camaro_SS's Avatar
 
Drives: 2010 Camaro 1SS (BLACK)
Join Date: Jan 2010
Location: Cali
Posts: 855
So Iíve watched almost all the videos about cutting out the plastic piece. I see that the heater core is extremely close behind the cut. How do people avoid not hitting it or cutting it? Do you just have to be extremely careful when on that side and barley cut through the plastic at the left side? Just from the vids it seems itís like a quarter to half an inch behind the cut which scares me lol.
__________________
_________________
1SS: Dnyatech LT Headers | Dynamaxx CatBack | Diablo Tune | Intake | Pfatds Springs | Heritage Grill | Blacked out Bezels | Black Chevy Sign | Blacked out Wheels | Tint | HIDs w/Error code Eliminator | Green Dome/Trunk Light |

Cali_Camaro_SS is offline   Reply With Quote
Old 06-12-2022, 08:56 PM   #10
Jwelsh
 
Drives: 2014 Camaro SS/RS
Join Date: Dec 2017
Location: New Mexico
Posts: 5
Quote:
Originally Posted by Cali_Camaro_SS View Post
Hey, so recently my ac has stopped blowing cold air and is just very warm. I went to autozone and got a r-134a bottle and when I just put the hose on the low side valve the gauge showed at 55psi and was directly on the line between green and red.
My car is a 2010 SS LS3 with 67k miles. AC belt is still on, checked just incase.
Any ideas what I can do or should do?

Thanks.
Welcome to the busted blend door club. You have 2 options: 1) Have a shop do it and pay $3,000 or 2) Do it yourself doing the blend door hack. Iím just about finished doing mine and it wasnít that bad except the hot plastic landing on your face while your trying to keep from cutting to deep.
Jwelsh is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:58 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.