Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Bigwormgraphix
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V8 LS3 / L99 Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 07-15-2018, 05:05 PM   #2801
oldschoolkat
 
oldschoolkat's Avatar
 
Drives: 2013 SS Camaro
Join Date: May 2016
Location: Chicagoland area
Posts: 212
Best camaro tip ...just did it..last week...I run 93 only..felt like new again...bump

Sent from my SM-G960U using Tapatalk
oldschoolkat is offline   Reply With Quote
Old 08-05-2018, 05:36 PM   #2802
gregross
 
Drives: 2013 2SS RS LS3
Join Date: Mar 2013
Location: canada
Posts: 30
fuse pull

dealer I believe put in regular gas . rough idle sluggish. did fuse pull on my LS3 didn't seem to make any difference. not sure what to do next.
gregross is offline   Reply With Quote
Old 08-06-2018, 09:19 AM   #2803
Dusk_2SS
 
Dusk_2SS's Avatar
 
Drives: 2013 Dusk Limited Edition 2SS/RS
Join Date: May 2017
Location: Tacoma WA
Posts: 82
Quote:
Originally Posted by gregross View Post
dealer I believe put in regular gas . rough idle sluggish. did fuse pull on my LS3 didn't seem to make any difference. not sure what to do next.
Did you purge all the low octane 1st?
__________________
Dusk_2SS is offline   Reply With Quote
Old 08-06-2018, 09:45 AM   #2804
ChibiBlackSheep

 
ChibiBlackSheep's Avatar
 
Drives: 2012 2SS/RS, 1968 SS
Join Date: Feb 2012
Location: Southeast, PA
Posts: 1,443
Quote:
Originally Posted by gregross View Post
dealer I believe put in regular gas . rough idle sluggish. did fuse pull on my LS3 didn't seem to make any difference. not sure what to do next.
Clean your MAF, check your plugs. How many miles?
__________________

2012 Camaro 2SS/RS | 1968 Camaro SS | 2000 Monte Carlo SS | 2018 Regal TourX
ChibiBlackSheep is online now   Reply With Quote
Old 08-06-2018, 09:48 AM   #2805
Nb1081
 
Drives: 10 2ss/rs
Join Date: Jul 2018
Location: Shelby ny
Posts: 156
120,000 miles think they needed it first thing i did when i got car a lil over week ago it defintly helped me out had similar issues felt like missfire at idle
Attached Images
 
__________________
]10 2ss/rs ls3 pretty much stock sctx4 cai mbrp axle back bmr toe rods 10.4wires

I've always been crazy. It keeps me from going insane
Nb1081 is offline   Reply With Quote
Old 08-14-2018, 11:22 AM   #2806
propeople
 
Drives: 2013 WITHE SS
Join Date: Jul 2015
Location: Sao gabriel do oeste
Posts: 81
propeople is offline   Reply With Quote
Old 10-03-2018, 11:37 AM   #2807
zlathim
 
Drives: 2010 Camaro SS/RS M6
Join Date: May 2009
Location: Id
Posts: 35
Recently acquired 2010 SS M6. I pulled the fuses last night for a little more than 4 hours. i know it is recommended to go overnight, but I didn't want to fumble around with fuses at 6:30 am in the dark...

There wasn't any noticeable change in the performance of the car at all. Perhaps there has never been low-octane fuel in the car. Perhaps I didn't leave the fuses out for long enough. Either way, it was easy to do and worth the effort. I may even try keeping the fuses out overnight to see if that makes any difference.
zlathim is offline   Reply With Quote
Old 10-04-2018, 01:09 AM   #2808
Dusk_2SS
 
Dusk_2SS's Avatar
 
Drives: 2013 Dusk Limited Edition 2SS/RS
Join Date: May 2017
Location: Tacoma WA
Posts: 82
Quote:
Originally Posted by zlathim View Post
Recently acquired 2010 SS M6. I pulled the fuses last night for a little more than 4 hours. i know it is recommended to go overnight, but I didn't want to fumble around with fuses at 6:30 am in the dark...

There wasn't any noticeable change in the performance of the car at all. Perhaps there has never been low-octane fuel in the car. Perhaps I didn't leave the fuses out for long enough. Either way, it was easy to do and worth the effort. I may even try keeping the fuses out overnight to see if that makes any difference.
4 hours should have done it unless you pulled one wrong or like you said, it wasn't on the lower fuel table to start with.
__________________
Dusk_2SS is offline   Reply With Quote
Old 10-04-2018, 03:00 PM   #2809
zlathim
 
Drives: 2010 Camaro SS/RS M6
Join Date: May 2009
Location: Id
Posts: 35
Quote:
Originally Posted by Dusk_2SS View Post
4 hours should have done it unless you pulled one wrong or like you said, it wasn't on the lower fuel table to start with.
I double checked, so I know I pulled the right fuses. It must not have been on the low octane fuel table to begin with.
zlathim is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 Camaro PCM Pin-out Description and Wire Colors (LS3 & L99) raptor Audio, Video, Bluetooth, Navigation, Radar, Electronics Forum 13 11-14-2015 04:07 AM
What kind of gas are you filling up with in your '10 Camaro? JewelZ 5th Gen Camaro SS LS LT General Discussions 42 08-02-2009 09:31 AM
Check your Order here bvonscott Camaro Price | Ordering | Tracking | Dealers Discussions 665 06-29-2009 01:00 PM


All times are GMT -5. The time now is 03:50 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.