Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Roto-Fab
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Engine | Drivetrain | Powertrain Technical Discussions > Camaro V6 LFX Engine, Exhaust, and Bolt-Ons


Reply
 
Thread Tools
Old 10-22-2017, 08:34 AM   #1
Lacpac
 
Lacpac's Avatar
 
Drives: 2012 Crystal Red Tintcoat RS
Join Date: Apr 2013
Location: Northern Illinois
Posts: 416
P0442 Check Engine Code

Not sure if you guys are aware, but there is a Technical Service Bulletin on the 2012 LFX for this problem. I erased my codes not realizing the dealer needs to see the code in your history so they can diagnose it and fix the Evap Solenoid problem.
Lacpac is offline   Reply With Quote
Old 10-22-2017, 03:06 PM   #2
Silent...
 
Silent...'s Avatar
 
Drives: 2012 2LT RS White Born: 11/10/11
Join Date: Nov 2011
Location: Florida
Posts: 315
Plenty of discussion on it already. Search. Replaced the fuel cap on mine and took care of it in my case.
__________________
*Grey Hockey Stripes; Heritage Grill; GM GFX - Unpainted Argent Gray; GM Dovetail Spoiler; Rivercity Creations custom painted rear bowtie, RS & Taillight Bezels; MRR M017 Graphite Wheels; Nitto NT555 G2; ACS 4Teen Heat Extractor
*RX Catch Can;CAI; MF Exhaust; VMAX CNC Spiral Ported TB; Overkill Stage 1 Supercharger System; Hotchkis Comp Sway Bar Set w/ End Links, Cadillac CTSV 4 Piston Brembos on all corners with SS Black Hat Rotors

Youtube Channel - HPDE Driving Videos https://www.youtube.com/channel/UCpO...8aw6hgX3O1Uh7A
Silent... is offline   Reply With Quote
Old 11-11-2017, 06:32 AM   #3
blackswan

 
blackswan's Avatar
 
Drives: 2012 2LT/RS
Join Date: Oct 2011
Location: Northeast
Posts: 1,397
Some codes are "permanent" and not erased by many of the code readers. I have two readers and one shows it and the other doesn't after clearing.
blackswan is offline   Reply With Quote
Old 11-18-2017, 07:43 PM   #4
blackswan

 
blackswan's Avatar
 
Drives: 2012 2LT/RS
Join Date: Oct 2011
Location: Northeast
Posts: 1,397
Quote:
Originally Posted by blackswan View Post
Some codes are "permanent" and not erased by many of the code readers. I have two readers and one shows it and the other doesn't after clearing.
Here was my cause of P0442
Attached Images
   
blackswan is offline   Reply With Quote
Old 11-28-2017, 02:31 PM   #5
Lacpac
 
Lacpac's Avatar
 
Drives: 2012 Crystal Red Tintcoat RS
Join Date: Apr 2013
Location: Northern Illinois
Posts: 416
Photos cause of 0442

So what are these photos showing. Vac leak?
Use zip ties to fix? The dealer said next time the code shows, don't erase it and they will diagnose then replace the part. I already replaced the gas cap.
Of course I've been code free since the last one in October.
Lacpac is offline   Reply With Quote
Old 07-29-2018, 06:45 AM   #6
blackswan

 
blackswan's Avatar
 
Drives: 2012 2LT/RS
Join Date: Oct 2011
Location: Northeast
Posts: 1,397
The top photo with yellow circle is showing that the hose came off. I took that picture when I removed the engine cover and there it was just sitting like that.
blackswan is offline   Reply With Quote
Old 08-02-2018, 12:37 PM   #7
Lacpac
 
Lacpac's Avatar
 
Drives: 2012 Crystal Red Tintcoat RS
Join Date: Apr 2013
Location: Northern Illinois
Posts: 416
In will have to check that. I haven't had the code appear since the one time last year. Some say it happens when you get low in the gas tank. Already replaced gas cap. That might have been the trick. I did do the PCV drill mod but that was long before the code showed up. I'll check those hoses again. Thanks.
Lacpac is offline   Reply With Quote
Old 08-02-2018, 01:29 PM   #8
Marklar
 
Drives: 2012 Camaro LS V6
Join Date: Aug 2016
Location: Ohio
Posts: 121
Funny that this thread come up now after almost a year. I just had this code happen on my car AND I replaced my gas cap AND the code persists. My local parts store said it's common and doesn't really affect anything but if the new gas cap doesn't take care of it I will probably have to replace the evap solenoid (pump?) and it's like a $50 part that takes 10 mins to replace. He said I shouldn't worry about it, but I still want the CEL to go away.
Marklar is offline   Reply With Quote
Old 09-15-2018, 09:54 AM   #9
SlickP
 
Drives: 2016 2SS Convertible
Join Date: Oct 2011
Location: Atlanta, GA
Posts: 249
I am having this same problem I replaced the gas cap and the check engine light is still on. I check for lose hoses and did not see anything. I was told to replace the EVAP solenoid. Should I take this to Chevy and pay them to fix this or just replace the part?
SlickP is offline   Reply With Quote
Old 03-24-2019, 09:55 AM   #10
blackswan

 
blackswan's Avatar
 
Drives: 2012 2LT/RS
Join Date: Oct 2011
Location: Northeast
Posts: 1,397
Quote:
Originally Posted by SlickP View Post
I am having this same problem I replaced the gas cap and the check engine light is still on. I check for lose hoses and did not see anything. I was told to replace the EVAP solenoid. Should I take this to Chevy and pay them to fix this or just replace the part?
Just replace it, will cost you at least that much to have them tell you to replace it anyway and then they will charge you a LOT more. Besides, they go bad, not the worst thing to have a new one installed and go from there. I'm planning on doing this and gas cap probably every 30k or so, sadly.
blackswan is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.