Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
Rick@Livernois
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Camaro Issues / Problems | Warranty Discussions | TSB and Recalls


Reply
 
Thread Tools
Old 02-16-2010, 07:12 PM   #1
SS Mike

 
SS Mike's Avatar
 
Drives: 2010 Camaro SS/RS CGM M6
Join Date: Jun 2009
Location: Orange County, California
Posts: 804
Please help!!! All lights on gauges coming on!!

So I've had my car for almost a year now, no problems whatsoever. About a week ago, I drove to work and parked like always. When I left for work, I put it in gear and drove like normal through the parking structure. Before I even got one level down in the structure, I had the ABS and Parking Brake lights come on. I checked and the parking brake was down. I turned the car off when I got out of the structure and restarted it. As soon as I got on the freeway they cam back on. On the drive home I got the low traction, traction control off, and stabilit control off lights on, plus a message in the DIC telling me to service the Stabilitrak system. I continued driving home when I got a check engine light.

When I got home I checked the codes with my tuner and got U0073 and P069E. U0073 is CAN Bus "A" turned off. P069E is Fuel Pump Control Module indicated to the ECU to turn on the check engine light. I cleared the codes to see if they were real or an error of some type. The next day they all came back on.

I decided to check the battery cables to make sure they were tight. They were. But I noticed water under and around the battery. I was convinced that water got in some connections or something and shorted something out. Whiel driving to a friends shop the next day the check engine light went away on its own, and I didn't get any other lights at all. I thought maybe it was water and it dried up and cleared itself.

The next day, all the lights came back on. A friend and I checked the battery again and found a little bit of rust around the battery ground bolt. Took the bolt out, sanded off the rust on the bolt threads, the washer, the connector, and the threads in the bolt hole. Hooked it all back up. A short while later, all the lights came back on. This time I got one ectra code, dont' remember the number but the description was ECU lost all control with the Fuel Pump Control Module.

Everytime I turn the key off and let the car sit, all the lights, EXCEPT the check engne light, go away, but then come back on while driving.

I brought it to the dealer today and they took a look at it. The tech can't figure out what the problem is and he wants to clear the codes, leave it over night and drive it a bit tomorrow. They said they think it is the tune from Vortech. Vortech and myself do not believe this as they don't change any perameters regarding communication with any of the modules. My friend who is a MBZ tech believes it is a CAN-bus failure due to a module malfunction either from water, corrosion, or something else. The dealer said that there are about 20 codes being shown, and neither them nor I believe there is any way that 20 systems can be broken at once, especially when the car still drives normal.

Any help is appreciated, hopefully there are some techs on here that have dealt with a CAN-bus error or malfunction before. Please if you have any ideas or suggestions let me hear them.

Thanks!

-Mike
__________________

Vortech V-3 Kit, ARH LT's, Custom Exhaust, Aeromotive A1000 Fuel System, Custom Tune - 582 rwhp 533 rwtq
22" Modulare H2 Wheels, CF Hood, Trunk, Spoiler & Roof by Carbon by Design, Custom Steering Wheel from P-Factor
Brembo GT BBK, Alpine INA-900, Alpine Type-R Speakers, Hurst Shifter, APR Splitter, Custom Quad Tip Diffuser
CKS C1 Coilovers, Falken 452 Tires, 265/35/22 & 285/35/22, Custom Grille, AAC Halos, and much more to come!!

Last edited by SS Mike; 02-17-2010 at 07:11 PM.
SS Mike is offline   Reply With Quote
Old 02-16-2010, 07:23 PM   #2
hb35man
 
hb35man's Avatar
 
Drives: 2010 Camaro 1LT Aqua Blue Metallic
Join Date: Dec 2009
Location: Algona Washington
Posts: 316
Wow! I don't want to make light of your predicament but.............your car doesn't leave in the middle of the night by itself and come back the next day does it?
When you find the problem let everybody...including GM...know. With the technology available today an electrical malfunction of that magnitude is
inexcusable.Good luck
hb35man is offline   Reply With Quote
Old 02-16-2010, 07:28 PM   #3
SS Mike

 
SS Mike's Avatar
 
Drives: 2010 Camaro SS/RS CGM M6
Join Date: Jun 2009
Location: Orange County, California
Posts: 804
Quote:
Originally Posted by hb35man View Post
Wow! I don't want to make light of your predicament but.............your car doesn't leave in the middle of the night by itself and come back the next day does it?
When you find the problem let everybody...including GM...know. With the technology available today an electrical malfunction of that magnitude is
inexcusable.Good luck
Haha, no problem, right now I'm trying not to worry so that helps!!

Agreed, but it's not AS bad as it sounds. The CAN-bus basically receives inputs from every major system in the car and relays those messages to the ECU when needed. So when one system fails, they can all fail. I don't mean if one module goes bad all the rest will, but at least with the lights if there was one short, or communication error to the CAN, then that could make all the others incapable of communicating which makes the lights come on. I just don't know where to begin when diagnosing this, and apparently neither does the dealer, yet.

I will let everyone know what it was though, if and when we figure it out.
__________________

Vortech V-3 Kit, ARH LT's, Custom Exhaust, Aeromotive A1000 Fuel System, Custom Tune - 582 rwhp 533 rwtq
22" Modulare H2 Wheels, CF Hood, Trunk, Spoiler & Roof by Carbon by Design, Custom Steering Wheel from P-Factor
Brembo GT BBK, Alpine INA-900, Alpine Type-R Speakers, Hurst Shifter, APR Splitter, Custom Quad Tip Diffuser
CKS C1 Coilovers, Falken 452 Tires, 265/35/22 & 285/35/22, Custom Grille, AAC Halos, and much more to come!!
SS Mike is offline   Reply With Quote
Old 02-18-2010, 03:34 PM   #4
SS Mike

 
SS Mike's Avatar
 
Drives: 2010 Camaro SS/RS CGM M6
Join Date: Jun 2009
Location: Orange County, California
Posts: 804
Looks like the dealer was able to figure out the problem. Everything points to a faulty BCM (Body Control Module) which explains the Stabilitrak issues and the ABS/Emergency Brake lights coming on first, then messing up communication along the CAN. Should be fixed soon.
__________________

Vortech V-3 Kit, ARH LT's, Custom Exhaust, Aeromotive A1000 Fuel System, Custom Tune - 582 rwhp 533 rwtq
22" Modulare H2 Wheels, CF Hood, Trunk, Spoiler & Roof by Carbon by Design, Custom Steering Wheel from P-Factor
Brembo GT BBK, Alpine INA-900, Alpine Type-R Speakers, Hurst Shifter, APR Splitter, Custom Quad Tip Diffuser
CKS C1 Coilovers, Falken 452 Tires, 265/35/22 & 285/35/22, Custom Grille, AAC Halos, and much more to come!!
SS Mike is offline   Reply With Quote
Old 02-18-2010, 07:06 PM   #5
hb35man
 
hb35man's Avatar
 
Drives: 2010 Camaro 1LT Aqua Blue Metallic
Join Date: Dec 2009
Location: Algona Washington
Posts: 316
Quote:
Originally Posted by SS Mike View Post
Looks like the dealer was able to figure out the problem. Everything points to a faulty BCM (Body Control Module) which explains the Stabilitrak issues and the ABS/Emergency Brake lights coming on first, then messing up communication along the CAN. Should be fixed soon.
Glad they got it figured out.I wonder if it is an isolated case or if there are more out there having the same issue.
hb35man is offline   Reply With Quote
Old 02-18-2010, 07:27 PM   #6
68/2010
Emerald Coast Camaros
 
68/2010's Avatar
 
Drives: 2010 2SS Rally Yellow
Join Date: Feb 2009
Location: TALLAHASSEE,FL
Posts: 4,229
That's scary!!!!!!!!!!!!!! I'm glad you got your car fixed.
__________________
68/2010 is offline   Reply With Quote
Old 02-19-2010, 12:22 PM   #7
SS Mike

 
SS Mike's Avatar
 
Drives: 2010 Camaro SS/RS CGM M6
Join Date: Jun 2009
Location: Orange County, California
Posts: 804
Quote:
Originally Posted by 68/2010 View Post
That's scary!!!!!!!!!!!!!! I'm glad you got your car fixed.
Honestly I'm sure it's isolated, we won't know more until the module is pulled out and examined to find out why it went bad (if it is in fact the BCM). The problem isn't a design flaw on this car or anything, it's this style of car management, meaning using a CAN (Controller Area Network). All modules and systems communicate to other systems via the CAN. So when one has a problem, it's like a huge pile up on the freeway, nothing else can get through. So don't take this issue as something that GM did wrong, because they didn't, it's just the style of management, which many manufacturer's use.

I'll keep you posted when I get final word and everything is fixed.
__________________

Vortech V-3 Kit, ARH LT's, Custom Exhaust, Aeromotive A1000 Fuel System, Custom Tune - 582 rwhp 533 rwtq
22" Modulare H2 Wheels, CF Hood, Trunk, Spoiler & Roof by Carbon by Design, Custom Steering Wheel from P-Factor
Brembo GT BBK, Alpine INA-900, Alpine Type-R Speakers, Hurst Shifter, APR Splitter, Custom Quad Tip Diffuser
CKS C1 Coilovers, Falken 452 Tires, 265/35/22 & 285/35/22, Custom Grille, AAC Halos, and much more to come!!
SS Mike is offline   Reply With Quote
Old 02-19-2010, 01:00 PM   #8
1 BAD RS 2 SS
 
1 BAD RS 2 SS's Avatar
 
Drives: 2010 RS 2 SS
Join Date: Aug 2009
Location: FLEMING COUNTY , KY
Posts: 415
1 BAD RS 2 SS is offline   Reply With Quote
Old 02-19-2010, 07:22 PM   #9
camaroguy
MJ is finally home!
 
camaroguy's Avatar
 
Drives: 2010 CGM 2SS/RS Camaro M6
Join Date: Jan 2009
Location: Olathe, KS
Posts: 219
so your tune didn't void your warranty?
camaroguy is offline   Reply With Quote
Old 02-19-2010, 10:46 PM   #10
d69chris
Florida C5
 
d69chris's Avatar
 
Drives: 2010 Camaro 2SS Vortech L99 IOM
Join Date: Jul 2009
Location: Tequesta, FL
Posts: 2,610
Send a message via Yahoo to d69chris
__________________
Ordered 11/08/08....Del. 08/05/2009 Loving every minute of it! Don't hate me because i'm Pretty....
d69chris is offline   Reply With Quote
Old 02-22-2010, 12:39 PM   #11
SS Mike

 
SS Mike's Avatar
 
Drives: 2010 Camaro SS/RS CGM M6
Join Date: Jun 2009
Location: Orange County, California
Posts: 804
Quote:
Originally Posted by camaroguy View Post
so your tune didn't void your warranty?
Well now that is a question that I can't actually answer at this time. In this situation it did not appear that my modifications had anything to do with the module malfunction, so my warranty was unaffected. But that is just this time.

Also I found out the issue was the EBCM (Electronic Brake Control Module) not the BCM (Body Control Module), too many modules on this car!
__________________

Vortech V-3 Kit, ARH LT's, Custom Exhaust, Aeromotive A1000 Fuel System, Custom Tune - 582 rwhp 533 rwtq
22" Modulare H2 Wheels, CF Hood, Trunk, Spoiler & Roof by Carbon by Design, Custom Steering Wheel from P-Factor
Brembo GT BBK, Alpine INA-900, Alpine Type-R Speakers, Hurst Shifter, APR Splitter, Custom Quad Tip Diffuser
CKS C1 Coilovers, Falken 452 Tires, 265/35/22 & 285/35/22, Custom Grille, AAC Halos, and much more to come!!

Last edited by SS Mike; 05-27-2010 at 04:02 PM.
SS Mike is offline   Reply With Quote
Old 02-22-2010, 02:12 PM   #12
d69chris
Florida C5
 
d69chris's Avatar
 
Drives: 2010 Camaro 2SS Vortech L99 IOM
Join Date: Jul 2009
Location: Tequesta, FL
Posts: 2,610
Send a message via Yahoo to d69chris
Quote:
Originally Posted by SS Mike View Post
Well now that is a question that I can't actually answer at this time. In this situation it did not appear that my modifications had anything to do with the module malfunction, so my warranty was unaffected. But that is just this time.

Also I found out the issue was the EBCM (Electronic Brake Control Module) not the BMW (Body Control Module), too many modules on this car!
What dealer are you using, I may need them sooner rather than later.....
__________________
Ordered 11/08/08....Del. 08/05/2009 Loving every minute of it! Don't hate me because i'm Pretty....
d69chris is offline   Reply With Quote
Old 02-24-2010, 07:24 PM   #13
SS Mike

 
SS Mike's Avatar
 
Drives: 2010 Camaro SS/RS CGM M6
Join Date: Jun 2009
Location: Orange County, California
Posts: 804
OK update on the car, not that it's much of an update, but now I'm getting particularly frustrated at GM.

The EBCM has apparently malfunctioned on my car, as I stated above. GM wanted the tech to send them all the info on the ECM so they can review for warranty claim. No problem with that. However, When I brought my car in over a week ago, I told the dealer I needed the car back befre this Friday as I have a prior obligation that my car needs to attend in San Francisco. The service advisor and tech were both aware of this. So when GM asked for all the info from the ECM, I knew it would take them days if not longer to go through it all and figure out what they want to do about it.

So I told the dealership, put me down as a paying customer, thinking that if I am paying for this piece, they will send me one. Nope wrong. I find out today after the dealer talked to three different GM reps that they are WITHOLDING the part because it is on restriction!!! Now I can understand them putting a restriction on the part if I were claiming warranty, but now I am paying for my car to get fixed and I'm paying full retail for the broken part as well. GM still WON'T GIVE ME MY PART. Now I'm pissed because not only am I paying full retail for parts and labor, my car has been there for over a week, and most of the time it's been sitting there getting dirty waiting for GM to figure out what to do.

GM is now going through all the info from my ECM to try and diagnose the problem based on what the computer is telling them. In the meantime, my car isn't getting fixed, they won't give me my damn part, and I now have to drive 600 miles in the rain with NO ABS. Basically I paid $40k for a car from GM, and they won't release a $400 part (that I'm paying for!!!!) to me because it BROKE!!!

Just know that everyone at the dealership, from the tech, the advisor, to the service manager are all helping me out as much as they can, and I think the world of them. Now it's GM's turn to return the favor for me buying this car, they need to give me my part so I can fix the damn car!
__________________

Vortech V-3 Kit, ARH LT's, Custom Exhaust, Aeromotive A1000 Fuel System, Custom Tune - 582 rwhp 533 rwtq
22" Modulare H2 Wheels, CF Hood, Trunk, Spoiler & Roof by Carbon by Design, Custom Steering Wheel from P-Factor
Brembo GT BBK, Alpine INA-900, Alpine Type-R Speakers, Hurst Shifter, APR Splitter, Custom Quad Tip Diffuser
CKS C1 Coilovers, Falken 452 Tires, 265/35/22 & 285/35/22, Custom Grille, AAC Halos, and much more to come!!
SS Mike is offline   Reply With Quote
Old 02-24-2010, 10:49 PM   #14
HeavyD

 
HeavyD's Avatar
 
Drives: 1SSRS RY L99
Join Date: Aug 2009
Location: Ontario
Posts: 1,329
Probably don't have a warehouse with 100's of Body Control modules for a 2010 Camaro kickin' around. I am frustrated with you, but be patient.
HeavyD is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Removal of tail lights Germann Camaro DIY & HOW-TO instructions & discussions 8 12-14-2010 09:43 PM
Where is my RS logo and Fog lights?? nyknicks2315 5th Gen Camaro SS LS LT General Discussions 57 02-24-2010 10:30 AM
fog lights again BigTrap1967 Mechanical Maintenance: Break-in / Oil & Fluids / Servicing 9 09-14-2009 09:09 AM
lights wont go off Parrish 4th Generation Camaros 3 09-09-2009 09:11 AM
Parking lights ? Becustom Cosmetics and Lighting Modification Discussions 1 08-16-2009 11:12 AM


All times are GMT -5. The time now is 06:39 AM.


Powered by vBulletin® Version 3.8.9 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.