Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com
 
River City Camaro Customs
Go Back   Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com > Technical Camaro Topics > Suspension / Brakes / Chassis

Suspension / Brakes / Chassis All suspension, brakes and chassis discussions.

Reply
 
Thread Tools
Old 07-27-2013, 07:27 PM   #1
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: DFW
Posts: 1,329
Finally pedderized. Now an interesting problem

Took me twice as long as it should have, but I'm finally done with the xa coilovers, zl1 conversion sway bars, and a few bushings. I would take some pictures but.... I'm stuck in my garage. There is a hump to get down to the parking lot. I thought I would have clearance with the header clamps but I don't. It's not a super aggressive drop. 660mm. Time to pick up some 4x6's and build a ramp. I may get some pics up by tomorrow afternoon.
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 07-27-2013, 09:44 PM   #2
rockrau
 
rockrau's Avatar
 
Drives: 2010 2ss red
Join Date: Aug 2011
Location: perkasie pa
Posts: 365
rockrau is offline   Reply With Quote
Old 07-28-2013, 01:09 PM   #3
Denis


 
Denis's Avatar
 
Drives: 2010 SS
Join Date: May 2012
Location: Lexington Park, MD
Posts: 5,787
Haha. Not the worst problem to have. I mean its a problem but not as bad of an issue as I was expecting to read about lol
__________________
Denis is online now   Reply With Quote
Old 07-28-2013, 03:17 PM   #4
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: DFW
Posts: 1,329
Alright. I got it out the garage to take for a test drive and some pictures. Couldn't really hammer it because I notices some clunking from the rear end and lower speeds over small bumps. Higher speeds and larger jolts I couldn't hear it. I rechecked all bolts that attach to the lower control arm 2 times. I'm not really sure what could be making the noise. I suspected the drop links, but they are on there pretty tight. No play at all. I may need to head over to ADM and get my gears and sub frame bushing put on earlier than expected while they look at my mess that I did.

It looks great however. I have it set to 660MM. I didn't want to go too low.
Attached Images
  
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 07-28-2013, 04:04 PM   #5
Denis


 
Denis's Avatar
 
Drives: 2010 SS
Join Date: May 2012
Location: Lexington Park, MD
Posts: 5,787
Wow. Looks awesome.
__________________
Denis is online now   Reply With Quote
Old 07-28-2013, 04:35 PM   #6
rockrau
 
rockrau's Avatar
 
Drives: 2010 2ss red
Join Date: Aug 2011
Location: perkasie pa
Posts: 365
Welcome to the Pedders Nation!
rockrau is offline   Reply With Quote
Old 07-29-2013, 08:49 AM   #7
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,384
If you'll be at the FEST we can trouble shoot the noise at Bruce Raymond's.
__________________
JusticePete is offline   Reply With Quote
Old 07-29-2013, 09:21 AM   #8
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: DFW
Posts: 1,329
Quote:
Originally Posted by JusticePete View Post
If you'll be at the FEST we can trouble shoot the noise at Bruce Raymond's.
I really wish I could. They need to have a fest in TX!
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 07-29-2013, 09:44 AM   #9
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,384
Quote:
Originally Posted by ackeight View Post
I really wish I could. They need to have a fest in TX!
Ok.

1. Double check all the bolts in the rear.
2. With the tighter suspension, exhaust noise can occur that wasn't present with the softer OE setup. Look for any possible points of conact and adjust as necessary.
3. Pull the rear struts and verify the assembly stack is in order.
__________________
JusticePete is offline   Reply With Quote
Old 07-29-2013, 10:20 AM   #10
Raptor3141
 
Raptor3141's Avatar
 
Drives: 2010 2SS/RS RJT M6
Join Date: Aug 2012
Location: Milwaukee, WI
Posts: 205
Did you remember to clock the bushings? I noticed the same type of clunking sounds in the way to the alignment shop. Completely cleared up after clocking.
Raptor3141 is offline   Reply With Quote
Old 07-29-2013, 10:38 AM   #11
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: DFW
Posts: 1,329
Quote:
Originally Posted by Raptor3141 View Post
Did you remember to clock the bushings? I noticed the same type of clunking sounds in the way to the alignment shop. Completely cleared up after clocking.
I haven't got it aligned yet. I may do that, but I would hate for that not be it and have to disassemble just to have to realign.
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 07-29-2013, 01:35 PM   #12
jeremywes
 
jeremywes's Avatar
 
Drives: 2012 Camaro SS
Join Date: Aug 2012
Location: Houston, TX
Posts: 506
Quote:
Originally Posted by ackeight View Post
I really wish I could. They need to have a fest in TX!
Tru dat!
jeremywes is offline   Reply With Quote
Old 07-29-2013, 03:36 PM   #13
caverman


 
caverman's Avatar
 
Drives: '69 SS Convertible
Join Date: May 2009
Location: DFW, TX
Posts: 7,066
Quote:
Originally Posted by ackeight View Post
I haven't got it aligned yet. I may do that, but I would hate for that not be it and have to disassemble just to have to realign.
You shouldn't have to disassemble anything for the alignment. Hopefully you have some Pedders rear camber bolts though. They make a big difference in alignment for a lowered car. I was skeptical that they would really help at first but now that I have them and have had my car aligned I'm a believer.

You should still "time" your bushings. If you've done some the trailing arms along with your LCA then you've already done some of this but you will probably need to go in and do the front.

BTW: I use a guy up in Denton that does a pretty good job and he's cheap as well. Normally only $70 for an alignment. Last time I had him install my camber bolts as well and he only charged me another $20 ($90 out the door) and him almost got it perfect to the Pedders Aggressive Street specs. PM me if you want his info.
__________________
-2010 Camaro 2SS | M6 | VR w/White Stripes | 1 3/4" KOOKS - 3" Magnaflow | LPE 3.91 gears | ADM tuned | Halltech w/ADM Scoop | Spohn/BMR Trailing Arm/Toe Rod | BC Coilovers| Pedders FE4 ZL1 swaybars | Cradle/Diff/Radius Rod bushings | VMax TB | Morimoto Projectors | MGW shifter | Red Calipers
Build Journal
caverman is offline   Reply With Quote
Old 07-29-2013, 04:34 PM   #14
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: DFW
Posts: 1,329
Quote:
Originally Posted by caverman View Post
You shouldn't have to disassemble anything for the alignment. Hopefully you have some Pedders rear camber bolts though. They make a big difference in alignment for a lowered car. I was skeptical that they would really help at first but now that I have them and have had my car aligned I'm a believer.

You should still "time" your bushings. If you've done some the trailing arms along with your LCA then you've already done some of this but you will probably need to go in and do the front.

BTW: I use a guy up in Denton that does a pretty good job and he's cheap as well. Normally only $70 for an alignment. Last time I had him install my camber bolts as well and he only charged me another $20 ($90 out the door) and him almost got it perfect to the Pedders Aggressive Street specs. PM me if you want his info.
I do have the camber bolts. This sound is metal to metal like. I may time the lca bushing and lower strut bushing tomorrow. That's about all I can get to before an alignment.
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 07-29-2013, 04:52 PM   #15
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,384
Timing the bushings should not create a metal to metal noise. Can you snap and post spring pictures? Just snap the best you can with the car sitting on the ground.
__________________
JusticePete is offline   Reply With Quote
Old 07-29-2013, 07:52 PM   #16
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: DFW
Posts: 1,329
Quote:
Originally Posted by JusticePete View Post
Timing the bushings should not create a metal to metal noise. Can you snap and post spring pictures? Just snap the best you can with the car sitting on the ground.
Not the best pics since I didn't have a lot of room to work with. I pretty sure I assembled them correctly. Both washers are on there with the worn sides facing the mount. Isolator is on there. Pre loaded hand tight then 10mm.

Name:  ImageUploadedByTapatalk1375145506.430828.jpg
Views: 464
Size:  132.9 KBName:  ImageUploadedByTapatalk1375145516.529879.jpg
Views: 474
Size:  159.4 KB
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone

Last edited by ackeight; 07-29-2013 at 08:27 PM.
ackeight is offline   Reply With Quote
Old 07-29-2013, 08:31 PM   #17
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,384
Looks right. What speed can you hear the noise?
__________________
JusticePete is offline   Reply With Quote
Old 07-29-2013, 08:46 PM   #18
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: DFW
Posts: 1,329
It's most noticeable at speeds below 15. Although I can hear it a little at faster speeds.
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 07-29-2013, 08:55 PM   #19
GTAHVIT
One Lucky Guy.
 
GTAHVIT's Avatar
 
Drives: #22 Tom Henry Racing 2010 2SS/RS
Join Date: Dec 2007
Location: Saint Augustine FL
Posts: 28,774
I had almost exactly the same problem... Mine turned out to be the coil insulators not installed....

But you've got that one sorted... how about the rear swaybar D bush straps... if those aren't tight you could get the same noise.
Did your's come with the taller bushes?
GTAHVIT is offline   Reply With Quote
Old 07-29-2013, 08:59 PM   #20
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,384
Good idea to double check the strap bolts.

If you can find a safe spot in a parking lot do you have a trunk monkey available?
__________________
JusticePete is offline   Reply With Quote
Old 07-29-2013, 09:41 PM   #21
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: DFW
Posts: 1,329
Quote:
Originally Posted by GTAHVIT View Post
I had almost exactly the same problem... Mine turned out to be the coil insulators not installed....

But you've got that one sorted... how about the rear swaybar D bush straps... if those aren't tight you could get the same noise.
Did your's come with the taller bushes?
You are making me rethink which bushings I put in. I was sent both types for the rear(long story). The ones I put in fit pretty good. Here are the ones not installed. They are thicker up top compared to the ones on the car. Name:  ImageUploadedByTapatalk1375152071.618016.jpg
Views: 450
Size:  317.6 KB

Brackets were tightened to16 ft lbs
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 07-29-2013, 09:54 PM   #22
JusticePete
Rebel Leader
 
JusticePete's Avatar
 
Drives: Camaro Justice
Join Date: Jun 2007
Location: Texas
Posts: 15,384
You have a ten so the smaller bush is the correct fit.
__________________
JusticePete is offline   Reply With Quote
Old 07-29-2013, 09:56 PM   #23
ackeight

 
ackeight's Avatar
 
Drives: 10' 2SS/RS
Join Date: Jan 2010
Location: DFW
Posts: 1,329
The exhaust looks to be clear of everything. I may just wind up ripping out the whole rear and reinstall. If that doesn't work time for the pro's at ADM to look at it.
__________________
ADM tuned 412HP/407RWTQ. Kooks 2" headers w/ cats, ADM race intake, Vmax TB, Pedders XA coilovers and ZL1 sways. 1le clone
ackeight is offline   Reply With Quote
Old 07-29-2013, 11:32 PM   #24
caverman


 
caverman's Avatar
 
Drives: '69 SS Convertible
Join Date: May 2009
Location: DFW, TX
Posts: 7,066
Quote:
Originally Posted by JusticePete View Post
You have a ten so the smaller bush is the correct fit.
LOL....that's assuming he didn't change out the straps for some reason like I did. I found out the hard way that FE4 straps are 1/8" smaller than FE3 straps. So, Pedders has two different bushings for the ZL1 bar depending if you have FE3 or FE4 straps.

Ace....are the rear sway bar straps you have the OEM ones that came with your car?

I'll say that I never heard any noise when I had installed the wrong bushings. The say bar just was moving inside the straps when it shouldn't have.

Would it be possible at all to maybe try to get some video of it?
__________________
-2010 Camaro 2SS | M6 | VR w/White Stripes | 1 3/4" KOOKS - 3" Magnaflow | LPE 3.91 gears | ADM tuned | Halltech w/ADM Scoop | Spohn/BMR Trailing Arm/Toe Rod | BC Coilovers| Pedders FE4 ZL1 swaybars | Cradle/Diff/Radius Rod bushings | VMax TB | Morimoto Projectors | MGW shifter | Red Calipers
Build Journal

Last edited by caverman; 07-29-2013 at 11:43 PM.
caverman is offline   Reply With Quote
Old 07-30-2013, 12:18 AM   #25
L99CAMA2011


 
L99CAMA2011's Avatar
 
Drives: One of the baddest handling Gen 5s
Join Date: Feb 2011
Location: Masachusetts
Posts: 2,632
Has to be the strap and the wrong bush. Take a pic of the strap around the bar from a side. The FE4 straps are actually taller than FE3, I had both.
L99CAMA2011 is offline   Reply With Quote
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.