Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com

Camaro5 Chevy Camaro Forum / Camaro ZL1, SS and V6 Forums - Camaro5.com (http://www.camaro5.com/forums/index.php)
-   Camaro Issues / Problems | Warranty Discussions | TSB and Recalls (http://www.camaro5.com/forums/forumdisplay.php?f=70)
-   -   2010 Camaro Launch Control = Transmission Failure (http://www.camaro5.com/forums/showthread.php?t=30226)

camaroguy 06-30-2009 09:31 PM

2010 Camaro Launch Control = Transmission Failure
 
Ah, such much fun driving my Camaro. Took my neighbor out tonight for a ride and decided to hit the mall parking lot for a quick burnout. Well, didn't get to do the burnout, instead I decided to try out the Launch Control... So I get it into Competitive mode, mash the accelerator to the floor. I check, and its holding about 4200 rpms like it shoud.... Every thing looks fine and dandy... Dump the clutch... BAMMMMMMM!:facepalm:

Now here I am with my neighbor friend, and the first thing he says... " oh shit!, you're done..."....:facepalm: As far as I can tell, the tremec didn't hold up to the dump of the clutch. I can't get the camaro to move in gear now at all.. Leaking trans fluid going everywhere on the ground....:mad0259: called onstar.. Get everything set up to get it towed back to the dealer right now. I am sure the tremec's tail shaft snapped.. :mad0260:

So much for launch control... Maybe if I had slippery tires, it wouldn't of been a problem.. Oh, and while waiting for the Tow truck guy, here comes this ricer into the parking lot doing donuts and just making me feel worse about the whole situation.. I still love the Camaro though.. Now I have to sit and wait while I figure out what the dealer is going to do about it. :cry:

Anybody else's M6 transmission broke yet from burnouts/ launch control?

ljustin293 06-30-2009 09:33 PM

there was just a thread on here about something loose on the tranny...that might be what happened to yours...I hate to hear it for you..hopefully it can be fixed soon

Paperer 06-30-2009 09:36 PM

Damn man, that sucks. I wish the best for you and your car. Is there any video of anyone doing a successful launch??

ljustin293 06-30-2009 09:36 PM

here is that other thread http://www.camaro5.com/forums/showthread.php?t=29895

BackinBlackSS/RS 06-30-2009 09:37 PM

OMG that is terrible. Kinda scary considering it is something that is built in to the
traction control system and is something they tell you you can do. Let us know
what happened. Sorry, I feel bad for you and your baby. :(

coolman 06-30-2009 09:38 PM

Sounds like it's becoming a growing problem , and don't even need to be hard on it.

mlee 06-30-2009 09:43 PM

Something had to be wrong with it... I've seen plenty of good launches... At least you'll get it fixed early when they can't give you any grief... or shouldn't give you any grief...

ibznu2010 06-30-2009 09:44 PM

Sounds like manual is having trouble like under power autos. wtf Gm. i did not pay 40 gran for this shit.

camaroguy 06-30-2009 09:54 PM

Yeah, there must of been a weak part in the transmission to just break like that.. I am assuming something broke anyways due to the loud BAMM noise.. Can't really fault GM for it though since Tremec makes the unit... I'll find out more tomorrow when I call the dealer

mlee 06-30-2009 09:59 PM

Quote:

Originally Posted by camaroguy (Post 636792)
Yeah, there must of been a weak part in the transmission to just break like that.. I am assuming something broke anyways due to the loud BAMM noise.. Can't really fault GM for it though since Tremec makes the unit... I'll find out more tomorrow when I call the dealer

:word: Good luck and hope they get parts quickly...

fazm 06-30-2009 10:13 PM

cant fault gm for the unit, but you can fault them for picking the unit

JDBeck23 07-01-2009 10:15 AM

Just posted on the similar thread, but I'll reiterate... The LS3 and MN6 are not new parts... they've been on the C6 Vettes for a while now... any issues we experience with them, the C6 guys have already seen it too, and there's bound to be more parts availability for the tranny and motor than for the rest of the Camaro.

Im just sayin, it sucks dude... but it's not the end of the world... it could be worse, you could be waiting for parts that are only on the camaro... and since the factory hasnt caught up yet, you'd be waiting for a while.

Problems happen, give GM a chance to fix it before we all start jumping on the "quality control" bandwagon.

camaroguy 07-01-2009 10:44 AM

Dude, what are you talking about? You get this thread confused with another??

UCF w00t 07-01-2009 10:48 AM

It's not the fault of launch control, it's a problem with the output shaft of cars built in the mid 16thousands.

http://www.camaro5.com/forums/showthread.php?t=29895

http://www.camaro5.com/forums/showth...383#post634383

http://www.camaro5.com/forums/showthread.php?t=29989

GM is aware of the problem and apparently re-routed some cars to Detroit to get fixed after build but before delivery. Hopefully they get you a new transmission soon.

This makes #4 I believe, all built very close to each other.

1320junkie 07-01-2009 10:48 AM

Quote:

Originally Posted by fazm (Post 636879)
cant fault gm for the unit, but you can fault them for picking the unit

There are wayyy more that are holding up than that are breaking..perfection is nowhere to be found

UCF w00t 07-01-2009 10:53 AM

Quote:

Originally Posted by fazm (Post 636879)
cant fault gm for the unit, but you can fault them for picking the unit

Hey mustang boy, the TR6060 is used by the GT500, Corvette, Viper SRT10, Challenger, and others. You really wanna fault GM for picking the TR6060?

2010SLVRBULIT 07-01-2009 10:59 AM

WTF?..beginning to find 'lemons' in this fruitbasket..oh wow..maybe QC is shit up there after all..

camaroguy 07-01-2009 11:02 AM

Its just a quality control issue from Tremec. Won't cost GM anything, just send them back to Tremec for exchange. I'm not worried about it and I know its not a fault of GM and the launch control feature, however, will I try it again? I don't think so... lol I think I will only do full throttle rolling starts from now on...

garagelogic 07-01-2009 11:03 AM

Quote:

Originally Posted by UCF w00t (Post 638075)
Hey mustang boy, the TR6060 is used by the GT500, Corvette, Viper SRT10, Challenger, and others. You really wanna fault GM for picking the TR6060?

Same tranny, but maybe not the same specs. I know there is a difference between the T6060 in the Viper and what's in my car. Input shafts and outputs shafts are likely different, too.;)

Unfair 07-01-2009 11:03 AM

:facepalm:

GM, it's sad to know after all the QC holds things like this still happen to paying customers. i guess you can say it's a tremec issue, but it's gm's responsibility to make sure everything passes QC. idk just venting it sucks to see good customers getting screwed.

UCF w00t 07-01-2009 11:15 AM

Quote:

Originally Posted by Unfair (Post 638108)
:facepalm:

GM, it's sad to know after all the QC holds things like this still happen to paying customers. i guess you can say it's a tremec issue, but it's gm's responsibility to make sure everything passes QC. idk just venting it sucks to see good customers getting screwed.

Stuff like this always happens in any manufacturing process. The only way to test would be to do burnouts and hard launches in the parking lot before they're put on the train. Would you like them to do that? I don't see how customers are getting screwed. They're being taken care of. If GM said "your fault, not covered under warranty" that would be a different situation.

camaroguy 07-01-2009 11:24 AM

Yeah, my dealer is taking care of me.. I talked to the service manager this morning and told him that I dumped the clutch doing a launch and the damn thing snapped. He kept saying he was sorry to hear about it and that they will start on it this afternoon.

Rogue Leader 07-01-2009 11:27 AM

Quote:

Originally Posted by UCF w00t (Post 638154)
Stuff like this always happens in any manufacturing process. The only way to test would be to do burnouts and hard launches in the parking lot before they're put on the train. Would you like them to do that? I don't see how customers are getting screwed. They're being taken care of. If GM said "your fault, not covered under warranty" that would be a different situation.

Dude you have a VIN! congrats! Hope you get your car soon!

That said this problem could NEVER be caught in QC unless they had someone go out and launch every car. It sucks but it happens, at least they are stepping up and fixing it imemdiately.

Adam 07-01-2009 11:32 AM

your story made me lol. I mean, I know v8 guys maybe have a different mentality, but pulling into a mall to do a burnout? seriously?

UCF w00t 07-01-2009 11:34 AM

Quote:

Originally Posted by Rogue Leader (Post 638210)
Dude you have a VIN! congrats! Hope you get your car soon!

I should have it tomorrow or Friday. Fingers crossed. :)


All times are GMT -5. The time now is 08:14 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.